1

So, I'm looking to replicate the functionality of Keychain in every OS X until macOS Sierra. I have two passwords for my MacBook: the first is quite simple and logs me in, and the second is devilishly complex and unlocks my Keychain. On older systems, Keychain prompted for the complex password on boot but stayed logged in until I shut down. Now, Keychain prompts on boot but logs out every three hours (or perhaps when the computer sleeps), requiring that I log in many times in a session. I can see the benefit to this, but at the same time it's useless for me. I turn off my MacBook with regularity, so if stolen it will likely be off (and therefore not logged in) but the new password prompts seem to come at the worst times. Is anyone familiar with a way to revert to the old style (keep the Keychain logged in until I shut down)?

I should clarify: I have seen many questions about repeated Keychain password prompts. This is a different question. I know my password and can enter it, satisfying the prompt. I don't want my Keychain password to be my user password. I want the Keychain session to last until my Mac shuts down.

  • Check your keychain settings. In Keychain Access, select the "login" keychain, then choose Edit menu > Change Settings for Keychain "login". – Gordon Davisson Nov 21 '16 at 21:52
  • @GordonDavisson that's a good idea, but my "login" keychain is not set to lock after inactivity nor to lock after sleeping – Sllew Nov 21 '16 at 23:41
  • @GordonDavisson I tried selecting the "Lock after sleeping" option, and the behavior is different: my current problem is that it prompts when I try to access passwords, and the "lock after sleeping" behavior is to prompt after I open the lid. – Sllew Nov 22 '16 at 1:46
  • Hmm, is it possible you're seeing password prompts for the individual entries in the keychain, rather than unlock prompts for the keychain itself? In Keychain Access, try double-clicking one of the passwords you get prompted for, then select the Access Control tab, and see if the app that uses it is on the "Always allow" list. – Gordon Davisson Nov 22 '16 at 3:12
  • @GordonDavisson I've been trying that as the prompts come up, and it seems to be working at least part of the time. Thanks! – Sllew Nov 30 '16 at 22:30

You must log in to answer this question.

Browse other questions tagged .