1

I'd like to block just 4 specific websites but AFAICT there is no such option.

There's the option to "Limit Adult Content" but sadly it blocks way too much. For example it blocks stackexchange.com. I searched for restaurants on Google it blocked every single result. There's the option to only allow a whitelist of sites but that's not useful for me either. I'd have to add every result and every link I click on.

Effectively I'm looking for a blacklist option. Is there a way to do it? Maybe install a custom network profile or something?

Update #1

Well so profiles don't solve it. They just do the enable the same features as available from the settings.

Next thing is to look for passthru VPN software or something like that

2

Yes, this is possible with the use of restrictions. Follow these steps:

  1. Go to Settings
  2. Tap on General
  3. Tap on Restrictions
  4. Tap on Enable Restrictions
  5. Enter a restriction passcode
  6. Swipe up until you see the Allowed Content section
  7. Tap on Websites at bottom of the list
  8. Tap on Limit Adult Content
  9. This provides access to the Never Allow list
  10. Tap on the Add a Website... option located under Never Allow
  11. Add the four websites you want to block
  12. Exit Restrictions / Settings

Now these four websites will be blocked even though they may not be Adult content.

  • You didn't read the question. Not just those 4 sites will be blocked, 1000s more are blocked as well. *.stackexchange.com is blocked when that option is enabled even though I didnt' add it as one of the sites I want blocked. Please read the actual question before writing an irrelvant answer – gman Nov 22 '16 at 12:49
  • I did read the question, but since I tested this and was able to access stackexchange.com I offered my solution. Just for the record, I tested this on an iPhone 6s and 4th generation iPad (iOS 10) and an iPod Touch 5 (iOS 9). I blocked a govt website and my workplace on all 3 devices. These two sites were then blocked on Safari, Mercury and Dolphin. However, stackexchange.com was still accessible in all browsers and devices. The Stack Exchange app also worked on the iPhone and iPad (it's not installed on the iPod, so couldn't test it on that). So, my solution works fine for me. – Monomeeth Nov 22 '16 at 13:05
  • I see you've edited your question, so I decided to test this again on my wife's iPad Mini 2. Everything works fine, including stackexchange.com and searching for restaurants via Google. However, the two websites I blocked remained inaccessible via all of her installed browsers. She doesn't have the Stack Exchange app installed, so didn't test for that. In summary, I have now tested this on four separate devices, three on iOS 10 and one on iOS 9 and in all cases my solution has worked. Perhaps there is another issue causing your experience to be different? – Monomeeth Nov 22 '16 at 13:15
  • Thanks for checking all that. Maybe you need to be living in Japan or switch to Japanese language. It's blocking lots of Japanese websites. So the question still stands. I don't want to block any other sites period. Only the ones I specify. The "Limit Adult Content" option is blocking far more than just the specified sites. – gman Nov 22 '16 at 13:50
  • I am wondering whether one or more of the sites you're blocking is causing the problem? If you can share what they are I could test at my end. Otherwise you could test them one by one to see if/when the problem is replicated. – Monomeeth Nov 22 '16 at 21:44

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .