1

I regularly use my iMac as an external display for my macbook using target display mode (TDM). Since upgrading my iMac to Sierra, the screen locking behavior has changed in a disturbing way. I'm hoping there's a configuration flag I can set to revert to the old behavior. Here's the situation:

  1. I unlock the iMac. (log in to my account)
  2. Connect the two macs with thunderbolt.
  3. Hit command-f2 to enable TDM. iMac is now an external monitor for macbook.
  4. Use the macbook for a while. Lock the screen, walk away. Wait a long time.
  5. Unplug the thunderbolt cable.
  6. The iMac is logged in and unlocked. (!!)

Previously (before Sierra) on step 6, the iMac would have its account locked, which is of course what I want my mac to do if I haven't been using it in a long time.

How can I get my iMac to lock its account when it's being used as an external monitor in TDM mode? Right now, it seems using TDM is a major security hole for the iMac.

  • 1
    Did you perhaps turn off the screensaver on your iMac or have set a very high log off time - as far as i can remember activating TDM never put my iMac into sleep mode it just normally takes so long till i switched back that the normal log off from screensaver already started – konqui Nov 23 '16 at 7:01
  • Good guess, but no. The account goes to screen saver after a couple minutes of inactivity, and screen saver locks the account very quickly. At least all this works when not using TDM. – Leopd Nov 26 '16 at 3:32
1
+100

This should not happen at all if your iMac locks itself after a period of time without TDM.

To lock your iMac's account after a period of time, follow these steps:

  1. Choose Apple menu > System Preferences, click Security & Privacy, then click General.

  2. Click the lock icon to unlock it, then enter an administrator name and password.

  3. Click Advanced.

  4. Select “Log out after... minutes of inactivity.”

  5. Set the amount of time before the user is automatically logged out.

(quoted from https://support.apple.com/kb/PH18670?locale=en_US)

.

It definitively is supported to log out a user while using Target Display Mode (TDM):

Any apps that are open on your iMac remain open and active while your iMac is in Target Display Mode. (...)

If you've set your iMac to automatically log out, apps are paused or closed when this happens but your iMac remains in Target Display Mode.

From: https://support.apple.com/en-us/HT204592#options

.

Also check these options in System Preferences:

  • Energy Saver > Wake for network access (uncheck)
  • Security & Privacy > General > Require password immediately after sleep or screen saver begins (check)
  • Desktop & Screen Saver > Screen Saver > Start after: 1 Minute

Please let me know if this solves the issue.

  • Okay, this worked, but I still think there's a Sierra bug here. Before (when I was seeing this behavior), my settings were for screen saver after 2 minutes, password after 5 seconds, and wake for network access. When I changed to 1 minute, immediate and no-wake-for-net it started logging out properly. Thanks! – Leopd Nov 26 '16 at 3:53
  • @Leopd thanks for your reply. The .plist file (where the settings are stored) may have become corrupt. Often it helps to change a setting (+ a reboot) and to change it back to the original value. Let me know if this works for you. – oa- Nov 26 '16 at 7:09

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .