1

"i" in english is always "I". Is there a preference to autocorrect that auto corrects small "i" to capital "I" in macOS?

3
  • You said "'i' in english is always 'I'." and that's just not a true statement! The 9th letter of the modern English alphabet is used in both uppercase and a lowercase form depending on where and how it's being used. Setting an auto-correct to always change from lower case to upper case seems a bit ridiculous, unless you never type a word that isn't starting a sentence, is not a proper noun and doesn't contain the 9th letter of the modern English alphabet in any position other the first character. Nov 20 '16 at 18:41
  • 5
    @user3439894 I think it's fairly obvious they mean "i" as a word.
    – Tuesday
    Nov 20 '16 at 23:33
  • 3
    @user3439894 you should delete that comment, it is a nutty interpretation of the question. It is really odd for a mac user to not see what is intended here. Nov 20 '16 at 23:44
2

Try System Preferences/Keyboard/Text/ check Capitalize Words Automatically

(Only available starting with Sierra)

4
  • That will also capitalize the first word of a sentence, which you may or may not want.
    – Tuesday
    Nov 20 '16 at 23:34
  • @timothymh You mean the first letter, right? If you have examples of when that's not helpful, I can add it to the answer. Nov 21 '16 at 0:06
  • 1
    Yes, that is an accepted meaning of the word. I often prefer to type in lowercase when in informal settings, such as iMessages, Skype, and other internet chats.
    – Tuesday
    Nov 21 '16 at 6:50
  • 1
    An undesirable situation would be writing dialogue: "How are you?" he said. That setting causes "He" to be capitalized.
    – user11633
    Apr 23 '17 at 23:23
1

More specifically if you just want to capitalize the i as a word, in System Preferences > Keyboard > Text... add i to the replace column and I (capitalized) to the With column. It will capitalize i written by itself, but leaves it if it's within a word.

Replace i with capital i

(This only works in Sierra. El Capitan and I think earlier versions require 2 characters to create a text shortcut.)

4
  • I have Sierra installed, so I can't confirm that it works in previous versions, but I know this text replacement feature has been there for a long time. Here's an article referring to text replacement in El Capitan. As for words ending in "i", I typed this sentence in all lowercase in the Notes app: " I went down the mississippi in the river boat. " It capitalized the first "I" automatically and left all others alone. Another example, Minnie and I. It knew to capitalize the last i and leave the others alone.
    – Hurston
    Apr 23 '17 at 23:02
  • Hey Tom. Do you have any references for the 2 character minimum requirement? I can't find it in any documentation.
    – Hurston
    Apr 24 '17 at 16:21
  • 1
    It's not in any apple docs that I have found, but my El Capitan pops up error messages for single characters and spaces, and I remember from answering other questions like this that the problem was not solvable via these settings before Sierra Apr 24 '17 at 23:35
  • I have Sierra installed and get the popup warning about 2 character limit.
    – jason3w
    May 30 '18 at 23:33
-5
+50

Just type small "L" , it is as same as l

4
  • 2
    it might look the same but the underlying code is totally different and it would be foolish to use this fix for anything other than printing something right away on paper. Apr 22 '17 at 20:17
  • The letter L, written in lower case is l and is not at all the same as an i written in upper case i.e. I. Shown together, lI, you can plainly see they are not the same! Apr 22 '17 at 21:03
  • 5
    Why did this answer get the bounty? lol
    – user11633
    Apr 23 '17 at 23:24
  • @user3439894 Actually with the Helvetica font which Apple uses as the default for Mail, Notes, TextEdit, Pages, etc, these two letters do look the same, see here Apr 26 '17 at 17:48

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .