1

I've had my iPhone 6s from new since they came out last year, and recently updated to iOS10 (currently running 10.1.1). Prior to this, whenever I enabled Bluetooth on my iPhone, it was instantaneous: turn it on, boom, it was enabled.

However, since the iOS10 update, it can now take up to a full 20-30 seconds between pressing the button and for Bluetooth to be enabled (with the little icon showing in the top right). At first I thought it was broken, but now I'm used to the long delay and it irks me.

I've tried rebooting the phone, which appeared to have fixed it, but it was just a bit faster in enabling Bluetooth the first time I tried it afterwards; all subsequent attempts were as painfully slow as before (and I'm not convinced that first time wasn't just a coincidence).

Is there any particular reason for this with the latest iOS update? And/or is there anything I can do to fix it?

Update

This isn't a fix fix (which is why I'm reluctant to post it as an answer), but: when turning on Bluetooth via the control pane (flicking upward from the bottom of your iPhone screen), don't immediately dismiss the screen. If you keep it open for just a couple of seconds, usually Bluetooth turns on much more quickly. I've found that if I don't do this, Bluetooth might not come on for 20-30 seconds, and if I then open the control pane subsequently, the Bluetooth icon is highlighted... and then appears to turn itself off again.

Update #2

As of iOS 10.3x this no longer appears to be an issue on any of my iOS devices.

  • Have you taken it to the Apple Store? – At0mic Nov 20 '16 at 13:37
  • @IronCraftMan That actually hadn't occurred to me (I bought my phone from John Lewis). However, the closest one is 35 miles away and I don't have a car, so that's definitely more difficult for me to do. – indextwo Nov 20 '16 at 14:48
  • Just to try to focus on what may be the problem, could you repeat your test with Fi-Fi off? – dan Jan 9 '17 at 19:28
2

I'm having this issue as well. I went to Apple, they replaced my iPhone 6S due to both the bluetooth coming up with an error in diagnostics, as well as the battery issue thats plaguing 6S users. However, I am still having the same problem. I am convinced its software related and waiting for the new iOS patch. A bit concerned that the hardware diagnostics at the Genius Bar found a Bluetooth error as well, hopefully the software isn't damaging the hardware.

|improve this answer|||||
1

I have had same issue... it started in iOS 10.1 it was fine up to 10.0.2. I went to Apple Store with video of it on another phone as it was sometimes intermittent.. They did diags and found no errors but replaced it for me anyway.. The new one has same issue... I sure hope 10.2 fixes it..very annoying!

|improve this answer|||||

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .