2

There are several questions that seem similar, e.g., TextEdit shows dialogs about not having permission to open any files, but they're not exactly the same and none of the suggested fixes work. Correction: when I posted, I forgot that one of the ideas in those posts I hadn't tried. Because I was doing a long slow backup via rsync, I did not reboot. This morning after that completed, a reboot has removed the problem. But it would still be nice to understand why, and how to prevent—since it happened again today (see comments).

For more than a month, I've been using the "re-open windows on login" option to keep a few Textedit files easily accessible. No problem noted with an occasional save or opening a new one.

But today, I cannot save any of them nor open any new ones in my home directory. OS 10.12.1

  • There are no ACLs in the entire /Users tree.
  • There are no extended attributes on the file I am trying to open
  • There are no extended attributes on ~ nor on /Users
  • Windows I want to save have not yet been, so can't have extended attributes
  • sudo chmod -R u+r,u+w /Users did not fix it
  • sudo rm -rf ~/Library/Autosave\ Information did not fix it
  • touch created the file, and vim can open, edit, and save it.
  • The school has a service which monitors the LAN for suspicious traffic.

There are some recent unusual events which don't seem capable of causing this, but just in case:

  • A post-graduate student's MacBook Air failed right before her comprehensive exams. She's blind, so learning Windows overnight was not an option
  • I created a non-admin account for her on my MacBook Pro (MBP), help her set up VoiceOver, copied in her ~/Documents and a few other important items, and changed the UID (she was 502 on hers and 504 on mine)
  • Exams took three days (long difficult essay questions) during which she probably closed the lid to 'sleep' between tests rather than log out or shut down.
  • She logged out and handed me the MBP around ten hours ago.
  • I updated MalwareBytes and a scan found and removed OSX.Genieo (which AFAIK has to do with adware, not home permissions). The previous version never found anything and I suspect wasn't even scanning (it took less than a half-second to say that it found nothing in over 500GB!)

Any ideas on a fix or a cause?

  • A few notes: the default ~/ folder (or subfolders) has some attached ACLs like group:everyone deny delete. You may have to fix your user folder. A MalwareBytes scan doesn't examine all files. It uses a signature file to determine threats and scans certain files/folders only. Depending on your system it takes ~2-5 minutes – klanomath Nov 20 '16 at 18:04
  • I repeat: there are no ACLs anywhere in /Users on my MBP. Any that were there were removed by me long ago in response to bugs in Time Machine. And if any were replaced by the system, they were removed as soon as this problem appeared (and verified gone by 'ls -laet@') An antivirus scanner that only scans part of potentially infected files is useless. And if it only skipped SIP-protected directories, it would not have finished in a few microseconds. It did take about two minutes AFTER the upgrade to the latest version. – WGroleau Nov 20 '16 at 18:13
  • MB is no antivirus app. If you removed all ACLs, you should add this – instead of writing "There are no ACLs.." – because that's not the system's default. – klanomath Nov 20 '16 at 18:19
  • So, happens again. I have a few files open in TextEdit. At least two are new, and one I have been editing/saving several times today. Created a new one and tried to open it: "don't have permission" Tried to save one of the other new ones (so that I can reboot as before without losing it) and I don't have permission for that either. AARRGGHH. – WGroleau Nov 30 '16 at 20:28
  • Perhaps a silly question, but have you booted into recovery partition and run Disk Utility to check for and repair permissions issues? That would be my very first step here if I were asked to resolve a situation like this. – dr.nixon Nov 30 '16 at 21:14
3

This post fixed my TextEdit permission problem:

https://www.cnet.com/news/fix-permissions-errors-for-sandboxed-applications-in-os-x/

I quit TextEdit, manually cd'd to ~/Library/Containers, and moved com.apple.TextEdit to my home directory out of the way, then restarted TextEdit, and I was able to open files for which I was previously getting permission errors.

  • My MBP is currently half a world away, but this really appears to describe the problem. – WGroleau May 22 '17 at 20:44
  • 1
    Simply quitting and restarting TextEdit worked for me. – Kelvin May 23 at 23:33

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .