I have a problem with my AirPort / Wi-Fi hardware on my MacBook Pro.

I updated to macOS 10.12, Sierra, and then the Wi-Fi would not work. Nothing I do has made any change. I have tried SMC and NVRam resets. Have used a different AirPort card. Different hard drive as well.

I just get the AirPort menu bar icon with an X through it. Any help would be great as it is doing my head in.

  • Have you have the AirPort card replaced in your MacBook Pro? Have you been to an Apple Store because of the problem? Nov 19, 2016 at 17:16
  • 1
    Does the hardware show up in System Profiler? Nov 19, 2016 at 18:20

1 Answer 1


You are not alone in seeing this problem; the Apple discussion Hello, my iMac's wifi icon has an x in it and I cannot access wireless wifi on it, … has attracted a couple of answers.

Linc Davis's answer suggests the following possible cause and a multi-step solution:

Sometimes the Wi-Fi icon in the menu bar may falsely indicate that Wi-Fi is unavailable. That could happen if you switch between network locations, one of which doesn't have a Wi-Fi service.

Open the Network pane in System Preferences. A list of available network services appears on the left.

  • If Wi-Fi is in the list, select it, then from the popup menu labeled with a gear icon at the bottom of the list, select Make Service Active. Click Apply.

  • If Wi-Fi is not in the service list, click the plus-sign button at the bottom of the list, and then select Wi-Fi from the Interface menu in the sheet that drops down. Click Create, then Apply.

If there is a closed padlock icon in the lower left corner of the preference pane, click it and enter your administrator password to unlock the settings.

If the above steps don't solve the problem, Linc goes on to suggest deleting the computer's /Library/Preferences/SystemConfiguration/com.apple.airport.preferences.plist file and restarting.

Full instructions are in the discussion.

  • HI Graham, Thanks but none of that worked. I have now downloaded El capitan to another hard drive and installed that, still doesn't see the wifi card. Does anyone know if there's anything I can do in Terminal?
    – robert
    Nov 19, 2016 at 19:05
  • Please can you edit your question to answer the comments above; those about the hardware showing up in System Profiler and changing the AirPort card. Hopefully that will help prompt more suggestions for you to try. Nov 19, 2016 at 20:13

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .