5

If I quit iTerm2 I always get the "Quit iTerm2? All sessions will be closed." message - independent of the settings in preferences. I don´t tick the three options under "General/Closing" - all regarding the closing mechanism. Normally the message doesn't have to appear, does it?

It´s annoying that I cannot reboot my system without explicitly quitting iTerm2. If I don´t close is by myself the system will hang/block the shutdown.

3

Under "Preferences" -> "General" -> "Closing" was a "Confirm 'Quit iTerm2' command" checkbox which worked for me. The "Profiles" -> "Session" -> "Closing" -> "Do not prompt before closing" option did not help with the shutdown case.

I-term 2 general preferences

1

Well, after upgrading to Sierra and installing latest version of iTerm2 I've got the hint from iTerm2 self: In "Profiles" there is an option into default profile (Tab "session") named "Closing" which was always "on" - after setting to "Do not prompt before closing" the behavior of iTerm2 is like expected.

Disable quit message

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .