1

I have a really strange issue with MacVim + Tmux + Powerline Fonts.

  1. I can run MacVim from the dock or terminal and it correctly starts with Powerline fonts.

  2. When I start a tmux session, and launch macvim from tmux, any custom Font will not load. If I open the graphical font browser, the font is listed and selected, it just does not modify the font in the UI. If I select another system font, the UI font will change!!

I've tried copying the shell environments between tmux and the standard terminal, but it does not have any affect.

Does anyone know how tmux could be breaking my fonts in macvim session?

I'm seeing this issue in Sierra and the exact same config works in El Capitan.

  • Did you solved this one? I have same problem. – Luka Lopusina Jul 11 '17 at 11:37
  • Yeah, see the answer I posted. – cmcginty Jul 12 '17 at 9:15
  • I tried that package (reattach-to-user-namespace) but still I have same problem. My MacVim don't see powerline fonts and some other stuff. The problem is probably related to env variables but I am not sure how to solve it. Have you tried anything else? – Luka Lopusina Jul 12 '17 at 9:21
0

I stumbled over the solution with some searching. The issue issue can be fixed with the reattach-to-user-namespace tool.

$ brew install reattach-to-user-namespace

Add the following line to the end of your ~/.tmux.conf file

set-option -g default-command "reattach-to-user-namespace -l zsh"

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .