9

Last week I found out when I am in a Team Viewer meeting, Team Viewer is lowering my Macbook Pro's audio. It sets the audio around 10%. When I put it back at 100% it's not the full 100% (for example, it's hardly to hear my friends on Team Speak). When I quit Team Viewer my audio is back at normal.

Does anyone know what the problem is?

Edit

I created a video which will explain the problem: https://www.youtube.com/watch?v=JaiYha6XNno

2 Answers 2

8

TeamViewer only ducks the audio device you selected. So if you don't want this feature you should be able to simply select one that you do not need (in the Teamviewer settings, not in macOS).

E.g. I use a RØDE NT-USB external microphone as my sound card. I selected Built-In Line Out/In as my audio device. Now TeamViewer has no idea what to do. :)

It's an ugly hack but victor's solution didn't work for me.

5
  • I'll try this out the next time I'm using TeamViewer and TeamSpeak at the same time. May 9, 2017 at 12:18
  • 1
    Tried this out today, this solution works aswell. Thanks! May 16, 2017 at 17:24
  • 3
    Thanks this worked! (I first got confused and changed the Mac Output Device, but then realised you meant the option under Team Viewer > Preferences > Audio). Interestingly upon connecting with Team Viewer I still get some lowering of the volume, but it comes back up to normal a second later. Jun 24, 2017 at 19:57
  • Sorry I think I might be blind but I can't see the option to change the external microphone? imgur.com/a/3Y8X0
    – jackdh
    Jun 26, 2017 at 21:36
  • @jackdh, if you want to use a headset for TeamViewer and another application that makes sound you need to put both options on build-in device. Jun 27, 2017 at 7:46
12

This sounds like the audio ducking feature, commonly used by video chatting applications to temporarily lower the volume of other sounds.

To turn it off, go to Applications/Utilities/VoiceOver Utility.app > Sound

Uncheck "Enable audio ducking".

3
  • 1
    This definitely solves the problem for next runs of TeamViewer. In case you're already experiencing the problem and want to fix your volume level without restarting your computer, just close your currently opened TeamViewer app, and any other app outputting sound, open Activity Monitor, search coreaudiod and kill it. After you do that volume level will be restored to normal levels. Oct 27, 2018 at 16:07
  • Sadly, this is present the the most recent version too. It's quite painful.
    – vr_driver
    Oct 19, 2021 at 10:39
  • this easter egg i would never have found if not for the teamviewer glitch
    – Fakeer
    May 2, 2023 at 19:21

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .