1

I had a mail service working fine before till i made this upgrade in Server App and OSX.

I came from Server app 3 and OSX 10.9.5 to OSX 10.11.6 to Server app 5 and OSX 10.12.1, and when i tried to reload postfix in this version, i receive several warnings,

remote:~ root# postfix reload
postfix: warning: /etc/postfix/main.cf, line 690: overriding earlier entry: config_directory=/etc/postfix
/usr/sbin/postconf: warning: /etc/postfix/main.cf, line 690: overriding earlier entry: config_directory=/etc/postfix
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: use_sacl_cache=yes
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: imap_submit_cred_file=/Library/Server/Mail/Config/postfix/submit.cred
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: mydomain_fallback=localhost
postfix/postlog: warning: /etc/postfix/main.cf, line 690: overriding earlier entry: config_directory=/etc/postfix
postfix/postfix-script: refreshing the Postfix mail system
postsuper: warning: /etc/postfix/main.cf, line 690: overriding earlier entry: config_directory=/etc/postfix

I have tried some solutions from apple discussions (https://discussions.apple.com/thread/6784876?start=0&tstart=0) but i continue to receive the same output.

I am using my mail service as it came by default, i have not made any configuration, with old settings that i was using before.

Inside of that /etc/postfix/main.cf there is no config_directory=/etc/postfix,

mydomain_fallback = localhost
message_size_limit = 10485760
biff = no
mynetworks = 127.0.0.0/8, [::1]/128
smtpd_client_restrictions = permit_mynetworks permit_sasl_authenticated permit
recipient_delimiter = +
smtpd_tls_ciphers = medium
inet_protocols = all
inet_interfaces = all
config_directory = /Library/Server/Mail/Config/postfix
server_config_directory = /Library/Server/Mail/Config/postfix
compatibility_level = 2

Other entries are in this file.

Dont know but that missing entry of config_directory=/etc/postfix could be the problem and from what i am seeing it could be a problem when someone come from a previous versions of Server App/OSX. I am not sure but the system must assume old values from previous configurations, and it fails in this new version. The best way to solve this it could be from comparing with one fresh postfix installation.

Any one knows other ways to solve this?

1

I have the same problem using postfix reload in Yosemite server, with the same error. Postfix is running, however, and I can restart it by using the GUI in server.

Sierra's postfix config files are, in fact, in /Library/Server/Mail/Config/postfix/ and the files in /etc/postfix are not used and obsolete. Changing files in /etc/postfix won't do you any good. The file you need to sort out is /Library/Server/Mail/Config/postfix/main.cf

  • Those where obsolent entries, it seems that in Yosemite have add already those entries elsewhere but at least postfix was working properly. Now i have upgraded my Server app and OSX to the latest Server app 5 and OSX sierra, and i seriously dont recommend this. Apple have turned postfix and dovecot into Server App. Now you dont have control over both MTA and MDA like before through terminal. – SipriusPT Nov 22 '16 at 12:29
  • Sorry, I've posted a new topic, but some of the suggestions, like /Library/Server/Mail/Config/postfix , is missing, at least on my Sierra. – Dickster Apr 21 '18 at 5:50
0

I have had the problem but I don't use the Server app.

Here is what works for me:

$ sudo vim /etc/postfix/main.cf

Look for the line where there is "use_sacl_cache=yes" and comment it, do the same thing with:

"imap_submit_cred_file=/Library/Server/Mail/Config/postfix/submit.cred"

and

"mydomain_fallback=localhost"

Don't override anything, you've to always check if that parameter already exist; for this case:

postfix/postlog: warning: /etc/postfix/main.cf,

line 690: overriding earlier entry:

config_directory=/etc/postfix

After that this should work:

$ sudo postfix restart
  • Thank you Mansa for your answer and welcome to Ask Different :) Instead of writing clumsy HTML where the formatting tags compete with the content, you can use easy to write MarkDown. I have taken the liberty of editing your answer and replace HTML tags with MarkDown. Please find a handy guide https://apple.stackexchange.com/editing-help. The help text could also be accessed by clicking the ? button in the answering text area toolbar. – Nimesh Neema Aug 23 '18 at 11:48

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .