3

I am using macOS Sierra. Recently, the Mail app started having problems with attachments. On many (but not all) messages, attachments show up, but they are displayed as "Mail Attachment", not as the actual file name. Curiously, sometimes the correct icon shows up. I thought that maybe they needed some time to download, but waiting for hours does not solve it. I tried turning on and off the automatic attachment download and deleting the Mail Downloads directory, but that did not fix it.

This is an Exchange account, which may be part of the problem.

Any idea what could be causing this?

3
  • I have the exact same problem, and it's with an "Exchange" account as well... I don't know why it's doing this. I tried the "enable junk mail filtering", but it's not working. – M. Beausoleil Sep 12 '17 at 15:22
  • I have a similar issue where the attachment shows up with the same name and icon but OSX Mail is stuck on "Downloading" which never seems to progress. It feels like there is some sort of background thread or process that is supposed to be downloading that is somehow blocked. – Gray Aug 5 '19 at 17:18
  • HTto JCStone: I had the same problem, and I couldn't find an answer anywhere (Apple Forums, Century Link help line, etc.) until I found it here, via Google. This solved my problem. It was exactly what caused the problem. – Michael Brady Oct 17 '20 at 23:56
2

I found this post to be very interesting:

http://osxdaily.com/2016/12/17/fix-mail-not-showing-attachments-mac/

  1. Backup your computer
  2. Rebuild your email mailbox(es) (this may take a long time to run, be sure your connected to internet because it's going to reload all the mails)
  3. In your "Account Information", select Download Attachement that matters to you (all)
  4. Restart Mail.

Hope that helps

2
  • I actually verified (it took a long time for me to reload all the emails), but it seems to work! Finally. – M. Beausoleil Sep 14 '17 at 2:08
  • 1
    Worked for me to only Rebuild email mailboxes. But not sure about how many time it will last... – AnthoPak Mar 12 '19 at 14:33
2

I have been battling this problem for months and after an odd work around from Apple that only worked some of the time I found my problem. Within the "Mail app" in preferences you can add a rule to direct emails into specific folders. I accidentally found out that the reason the downloads would not complete was that I had made rules to transfer the email and that transfer would happen before the download was complete. I went into mail rules and stopped all the transfers and now the emails attachments completely download no problems.

1

Disabling "enable junk mail filtering" fixed it for me (Mail Preferences). I tried everything, this fixed it as a last ditch attempt before only using my phone as the goto device.

2
  • Junk email filtering was already disabled for me. – burger Dec 7 '16 at 1:44
  • Disabling "enable junk mail filtering" fixed it for me (Mail Preferences) as well – Luiz Breim Apr 19 '18 at 1:03

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .