This morning, I was using my Late 2008 MacBook when I found that audio wasn't working. The volume icon in the menu bar was grayed out and System Preferences said that my output was set to Digital Audio instead of Internal Speakers like it normally is (and Digital Audio is my only option).Sound preferences stuck on Optical digital-out

More surprisingly, the headphone jack has a glowing red light (I had no idea it could do that!).

Red light headphone jack in Late 2008 MacBook

Why is this happening? Can I do anything to fix it?

  • Have you tried resetting the SMC and NVRAM? Doing that should get rid of the problem assuming it's a software issue
    – NoahL
    Commented Nov 16, 2016 at 18:37
  • Same problem on MacBook Pro mid 2012. Reboot → same problem. Reset NVRAM → same problem. Reset SMC → same problem.
    – dan
    Commented Apr 2, 2017 at 8:59
  • I am running Yosemite 10.10.5, without any funny software touching the audio output. Upon the happening of this problem I noticed that the process coreaudiod was running at 84 % CPU and my MBP was heating like a fool and breathing the same way.
    – dan
    Commented Apr 2, 2017 at 9:08
  • Same problem here, too - I'm 98% sure my headphone port is bust such that the motherboard permanently detects the optical cable as being in there somehow. The speakers do work, though, I hear the chime at startup and it frustrates the hell out of me! I can't believe there's no software bypass somewhere that can disable the optical output and return the internal speakers option? Commented Mar 27, 2018 at 23:47

5 Answers 5


Old question but since I had 5 minutes ago the same problem, I'll post my solution:

The audio output is as Graham Min describes a double output, working for headphone jack or Toslink adaptor. In my case the problem appeared as I disconnected my headphones: OSX didn't switch to integrated output but stayed on digital (optical) output

This page describes an elegant non invasive solution and in my case the solution was as simple as connecting the headphones again, and diconnecting them gently.

Here the steps

  1. Plug your headphones back in.

  2. Play a bit of sound through them (e.g., a song), then stop the sound.

  3. Make sure Preferences is quit.

  4. Launch Preferences and open the Sound pane.

  5. While the Sound pane is open and set to Headphones, pull out the headphone plug from the jack.

  6. It will reset itself to "Internal Speakers" and you are good to go.


You should be able to restore normal audio by selecting Internal Speakers or Line Out in the System Preferences > Sound panel.

The light is because the headphone jack is also a TOSLINK port:

TOSLINK (from Toshiba Link) is a standardized optical fiber connector system. Also known generically as an "optical audio cable" or just "optical cable", its most common use is in consumer audio equipment (via a "digital optical" socket)



I'm going to quote: https://superuser.com/a/37804

Personally, I've had success gently using a toothpick to nudge the stuck pins.

See also: https://www.ifixit.com/Answers/View/59477/My+headphone+jack+glows+with+a+red+light

macRumors ref: No sound out of MacBook speakers & red LED in Headphone jack. The red light is probably because its a Mini-TOSLINK port.

There is a metal prong in the jack and sometimes it can be bent, causing the digital audio to be turned on when it shouldn't be.


The problem is there is a switch in the jack that tells it if you have a mini headphone plug or an optical plug plugged into the headphone port. The problem is when you remove the plug, the jack doesn't know it and keeps shining the red light to talk with the optical. This disables the internal speakers and you see digital out instead of internal speakers in the speaker conrtol panel. Plugging and unplugging the speakers may get it working right for awhile but it won't last forever.

And, for the brave hearted,

I slid a paperclip in, and pushed out a little metal on the side. That did the job, and I have internal sound again. And the digital red light, is now off.


I struggled for a long period of time trying to find an answer. Tried blowing in headphone jack but with my mouth not touching it, deleting audio files, updating OS, doing a toothpick trick.. almost gave up, but than I found this neat advice. Anyone who's having this problem, just put tour mouth directly on the port and blow as hard as you can. Viola. Problem solved!

  • Does not work...
    – JBernardo
    Commented May 4, 2020 at 0:59

Just go to /Library/Audio/Plug-Ins/HAL/AppleAVBAudio.driver/Contents/MacOS and run the AppleAVBAudio.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .