My Mid 2012 MacBook Pro 13" says I suddenly ran out of Storage space.

My Mac barely has any data and my upgrade to Sierra was a clean install. Nothing was ported from previous backups.

If you see the image below, the "System" section in the left column says that it is consuming 466.82 GB. What I don't understand is why does my Mac require so much space? As far as I know, it should never increase 50 GB of space. Any help is appreciated.

image here

6 Answers 6


Download OmniDiskSweeper and analyze your hard drive.

OmniDiskSweeper will show you the files on your drive, in descending order by size, and letting you decide what to do with them. Delete away, but exercise caution.

enter image description here

OmniDiskSweeper will show detail of space usage: Select System and start cleaning.

It could be the Time Machine backup file that takes almost all the free space.

  • 2
    I was very skeptical of this program at first - but it highlighted an obvious culprit to my storage. Mac OS counts Adobe Cache files as "system" files but this app highlighted them no problem. When After Effects was updated - instead of deleting old cache files - it just created a new cache folder for the updated version. I freed up 50gigs without a problem. Apr 17, 2018 at 15:42
  • 5
    @JustinKaz command line tool :du lists folder and file size at current directory,and when used recursively,it will analyze all folder and files on the hard drive,after sorting the result could have the same result as this program show.Omni is more like a GUI version of du.
    – FrontENG
    Apr 17, 2018 at 23:41
  • 1
    I use Disk Inventory X. The program is so stable that I have been using the same version since last 5-6 years. It is open source also. New version 1.2 was released only when Apple started giving warning about old binaries. Sep 17, 2019 at 7:08

I fixed it on mine, it was to do with the BELLMIN' Time Machine Queue Backup files (i.e. files that meant to go onto the Time Machine but haven't been moved yet due to the TM not reachable or away from home etc).

Do the following (no need to buy or download any additional tools):

  1. Go to Terminal

  2. List all TM objects by doing the following

    sudo tmutil listlocalsnapshots /
  3. It will come back with few items:

  4. Remove these by doing:

    sudo tmutil deletelocalsnapshots 2018-04-01-122047
    sudo tmutil deletelocalsnapshots 2018-04-01-183626

Where the date is taken from the output from step-3 above.

Leave it for a while to catch it's breath. You can check the disk space by executing the df -m command and notice the % of your Free Space, doing more df -m every few seconds will show an increase, once done it would stabilise.

  • 2
    It's worth noting that while local snapshots do consume physical disk space and High Sierra includes them in the System count, they are marked as ‘purgeable’ and you should never need to perform this manually, since macOS takes care of it automatically based on available disk space.
    – grg
    Apr 2, 2018 at 11:06
  • so "sudo purge" do the same thing to free up the space?
    – gpanda
    Jun 5, 2018 at 6:23
  • Just to add an additional data point, my issue was snapshots also, but created by Carbon Copy Cloner and not Time Machine. I suspect that the non-Time Machine-ishness of it was what caused my Daisy Disk to not recognize the purge-ability of it. More info from CCC here: bombich.com/kb/ccc5/leveraging-snapshots-on-apfs-volumes
    – Lanny Bose
    Jul 16, 2018 at 19:57
  • If you're using docker check the size of ~/Library/Containers/ Solved my problem.
    – devssh
    Feb 12, 2019 at 18:15
  • 1
    @gpanda i don't think the purge tool has anything to do with macOS purgeable space. man purge has a copyright year of 2005, which predates the macos feature by more than a decade
    – lukas
    Jul 16, 2019 at 13:46

Your system may need to reindex the file system to correctly show disk usage amounts. Indexing is handled by Spotlight. Using system preferences>spotlight, add your drive to the list of folders not to index for privacy reasons. Reboot and then remove that entry. Your computer will be slow during the reindex process, but after it should show the appropriate amounts.

As for figuring out where your disk is being weighed down, I like to use Grand Perspective. http://grandperspectiv.sourceforge.net/ It gives a visual graph of the files you have and how large they are.

  • Didn't help at all on my end.
    – herve
    Nov 30, 2017 at 17:49
  • After restart 11GB increased. Dec 15, 2017 at 6:26
  • 1
    Didn't help on my end. I've reindexed spotlight, cleared old TM machine backups, reformatted and restored the computer, disabled TM, ran OmniDiskSweeper, and I still can't figure out how system is taking up 55gb (I've slowly chipped away .5GB at a time)
    – James
    Mar 27, 2018 at 2:01

I had a similar problem with my "system" storage. Apple Support helped me discover that my FileVault was turned on and the encryption process had gone awry. To check this, click on the Apple icon --> System Preferences --> FileVault. If the greyed-out box says "Turn Off FileVault..." then your FileVault is on. To turn it off and decrypt your disk, you will need to click the padlock in the bottom left and enter your password.


I am an iOS developer.

What matters most is Xcode

Good to rm the Xcode Data: app archives data and Simulator data

  • app archives data

enter image description here

  • Simulator data

enter image description here

PS: find the relevant path

NSLog(@"Documents Directory: %@", [[[NSFileManager defaultManager] URLsForDirectory:NSDocumentDirectory inDomains:NSUserDomainMask] lastObject]);

  1. Stop using Time Machine. Use something else...

  2. Delete TM local backups -- this alone will save you many gigabytes of space.

  3. Stop using Spotlight. Use something else. I recommend "EasyFind" and "Find Any File".

  4. consider to Stop using hibernation mode if it's enabled.

4a. Delete the sleep image (from hibernation mode) if it exists.

more advice on Macrumours

  • 1
    Can you explain why you're against such long serving tools? Are you promoting CarbonCopyCloner etc.?
    – anki
    Sep 21, 2019 at 16:43
  • 1
    This is all very bad advice. At best, it represents extreme space-saving at a significant cost to functionality.
    – benwiggy
    Sep 21, 2019 at 16:48
  • I don't know CarbonCopyCloner. I googled and paste here, It feels OK
    – dengApro
    Sep 22, 2019 at 2:30

It seems many things can be reported as "system".

I found the simplest way to find out what was using up all the storage space was the following:

  1. make sure to have directory size showing in finder (In the menu bar, select View → Show View Options, then Check the box next to Calculate all sizes)

  2. then click in the finder menu Go and just put a single / in the search box, this is the root directory of your machine. It might take a while to calculate all the dir sizes.

  3. order the finder view files by size, then navigate down into the biggest ones then waiting for each child dir to calculate its size and follow the rabbit hole down! I was able to accurately find the culprit this way.

  4. You might want to turn on show hidden files/folders (Hold down Cmd + Shift + . (dot)).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .