17

Using macOS Sierra (latest 10.12.1) on iMac and iPhone (iOS 10), copy/paste (Universal Clipboard) doesn't work. All necessary connections and accounts are turned on and connected.

3
  • Ok, found the issue ...
    – Yatko
    Nov 16, 2016 at 0:00
  • Not exactly the same thing, but Pushbullet is something I've been using. Obviously you need to copy and paste into the app, but it's not that cumbersome to be honest.
    – Joonas
    Nov 16, 2016 at 10:48
  • While working on the iOS app, I used Charles to track my API requests. For using Charles you need to configure proxy on your WiFi network. While haveing the proxy configured I could not use C&P from Mac to iPhone. But after turning off the proxy, C&P started working just fine. Dec 10, 2021 at 9:02

6 Answers 6

11

If the copy feature was working in the past and all of a sudden it stopped working, then you could try either of the following options:

  1. Restart Bluetooth (Turn off & on) on both the devices (iPhone & Mac) - System Preferences --> Bluetooth --> Turn Bluetooth Off
  2. Sign Out and Sign In back to iCloud on both the devices (iPhone & Mac)

If neither works, you can restart both the devices and it should start working.


Apple's support page about Handoff: https://support.apple.com/en-us/HT209455

2
  • 2
    turning on bluetooth on both devices did the trick for me. Thanks Jul 22, 2021 at 17:26
  • Bluetooth turning off->on on both devises got the handoff working again for me! Dec 28, 2021 at 6:15
6

Universal Clipboard works with text, photos, and videos only! Make sure you're trying to copy one of these and try setting up UC again:

  1. Sign into iCloud on both devices, your Mac and iPhone, with the SAME Apple ID
  2. Make sure Bluetooth is turned on on both devices
  3. Make sure Wi-Fi is on on both devices
  4. Make sure both devices are connected to the same Wi-Fi network
  5. Make sure your devices are next to each-other

Troubleshooting:

  1. Test by copying your text from your Mac and pasting it on your iPhone first and if that works, try the other way.
  2. Try Signing Out from iCloud and Signing In again on both devices.
  3. Double-check that Wi-Fi and Bluetooth are turned on on both devices, try pairing them to make sure both work properly.
  4. Double-check that Wi-Fi again if you may have multiple networks in your area, you could be connected to the guest network or your neighbor’s router.
  5. Double-check that your have macOS Sierra (not El Capitan !) If still no luck, post a comment here :-O
2
  • Before disabling iCloud I suggest first checking that Handoff is enabled on both devices apple.stackexchange.com/a/430916/51046 Nov 16, 2021 at 19:02
  • 1
    @StéphaneBruckert - this did it for me. It was enabled on both devices, but turning the feature on and off fixed the issue. Thanks!
    – Nik
    Jan 10, 2022 at 11:35
2

Also make sure Handoff is enabled on both devices:

  • On Mac: System Preferences -> General -> Allow Handoff between this Mac and your iCloud devices.
  • On iPhone / iPad: Settings -> General -> AirPlay & Handoff -> Handoff
2
  1. open ~/Library/Preferences/com.apple.coreservices.useractivityd.plist
  2. delete ClipboardSharingEnabled key
  3. restart

source: https://forums.macrumors.com/threads/universal-clipboard-not-working-mac-iphone-iphone-mac.2231304/

1

You don't specify your iMac model?

Many of Sierra's new features are not supported even on Macs that are officially supported by the upgrade - go to Upgrade to macOS Sierra and scroll down to the Feature Requirements section to check full compatibility.

For the benefit of others, Universal Clipboard works on:

  • iMac (2012 or newer)
  • MacBook (early 2015 or newer)
  • MacBook Pro (2012 or newer)
  • MacBook Air (2012 or newer)
  • Mac mini (2012 or newer)
  • Mac Pro (late 2013)
0

This happened to me after changing my AppleID password, and the variations on "have you tried switching it off and on again?" I tried didn't help.

Then I read this post in the thread Paul Jianer Shi linked to, and I noticed I couldn't even see handoff-own-encryption-key when I ran Keychain Access. After logging out of iCloud on the MacBook and logging back in this key appeared, and UC started working to the iPhone but not vice versa. I then logged out of iCloud and back in on the phone and UC worked in both directions.

I admit this is yet another version of "have you tried switching it off and on again?", but being able to see the missing key come back made it feel slightly more scientific.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .