1

I used to be able to click through to the iTunes App Store on my Mac by clicking a link in Chrome, but now it just hangs on a "Connecting to the iTunes Store..." page. What to do?

  • itmss appears to no longer be in Local State. Or at least it's not in there for me. Tested with 58.0.3029.81 (64-bit) – petebocken May 2 '17 at 1:15
4

As of Chrome 58 on macOS, this setting is in a file called Preferences in the relevant profile folder for your Chrome application files. In other words, something along the lines of:

  • ~/Library/Application Support/Google/Chrome/Default/Preferences
  • ~/Library/Application Support/Google/Chrome/Profile1/Preferences
  • ~/Library/Application Support/Google/Chrome/Profile2/Preferences

depending on whether or not you have multiple user profiles and which one you are using.

Inside that file, search for itmss and change the entry to false so that Chrome opens iTunes links, in other words:

"itmss":false,

The equivalent entry for the Mac AppStore is macappstores, i.e.:

"macappstores":false,

Before making this change, be sure to:

  • quit Chrome
  • make a copy of the original file in case things get messed up
1

Navigate to your Chrome user data:

  • On Mac: ~/Library/Application Support/Google/Chrome/
  • On Windows: C:\Users\<USER NAME>\AppData\Local\Google\Chrome\User Data\

In the Local State file, remove the entry between commas that mentions itmss (e.g., "itmss":true,)—this will reset the iTunes link handler. Now you can check "Remember my choice" the next time Chrome goes to open an iTunes link.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .