0

I am trying to connect to Wi-Fi. It does get connected but there is no internet. I can't use Wi-Fi. Weird thing is that when I connect my iPad and iPhone to the same router/Wi-Fi they work perfectly fine. But my MacBook Air has some issue. How can I fix this problem?

My OS is 10.9.5.

Update

Wifi is working in safe mode.

  • Open the OS X network settings > wifi > advanced and hit > Renew DHCP Lease button. Open safari and reload the webpage you are trying to open – howdytom Nov 14 '16 at 22:36
  • Just tried it after your comment but still same issue. The thing is that it is keep getting the same ip after pressing renew dhcp lease. – Zafar Saleem Nov 14 '16 at 22:38
  • Is it any wifi you can't connect or is it a specific network you can't connect? – fsb Nov 14 '16 at 22:46
  • Is this a one time issue, and does it persist after reboot? – Kisa Ayano Nov 14 '16 at 22:47
  • #fsb I haven't tried with other wifi yet. For that I may go to Starbucks :(. # kisa this the first time it happened. I tried restarting my MacBook several times and also the router. The problem still exist. – Zafar Saleem Nov 14 '16 at 22:50
1

It sounds like that your network settings are corrupt.

Reset your wifi settings Another option could be to reset the network and wifi settings.

a) In Macintosh HD/ Library / Preferences / SystemConfiguration

com.apple.airport.preferences.plist

  • Move those files to the trash

  • Reboot your Mac

  • Reconnect to your wifi

b) Alternatively you can open SystemPreferences > Networks > select Wifi and delete it. In the second step re-add the wifi service again.

Upgrade to macOS If possible try updating your Mac to the latest macOS version. Open the AppStore and download Mac Sierra.

Disable Third-Party Software Do you use any kind of Firewall Apps e.g. Little Snitch. If so, temporarily disable them.

  • I couldn't find these files in that location at all. I will update once I have wifi :) – Zafar Saleem Nov 15 '16 at 0:12
  • It was called differently in OS X Mavericks. Do you see a file called com.apple.airport.preferences.plist? If so. Delete it and reboot your Mac. – howdytom Nov 15 '16 at 0:21
  • In safe mode wifi is working. See my update in question. – Zafar Saleem Nov 15 '16 at 0:24
  • I didn't find that file either – Zafar Saleem Nov 15 '16 at 0:34
  • Another option: Connect your MacBook with your router using a Ethernet cable. Than update to OS X 10.12 – howdytom Nov 15 '16 at 0:37
0

Have you tried resetting your computer's System Management Controller (SMC)?

For the MacBook Air, here’s what you do:

  1. Shut down your computer
  2. Keep the MagSafe adapter (power cable) plugged in.
  3. Press at the same time shiftoptioncontrol (on the left side of the keyboard) and the power button
  4. Let go
  5. Turn your computer back on with the power button.

Also, another thing worth doing is resetting your NVRAM.

To reset your NVRAM do this:

  1. Shut down your machine. Yes, a full shut down, not just logging out.
  2. Press the power button and then press the commandoptionpr keys. You have to make sure you press these keys before the gray screen appears or it won’t work.
  3. Hold those keys down until your Mac reboots again and you here the startup chime.
  4. Let go of the keys and let your Mac reboot normally.

Note: When you log back in you may need to readjust some of your system preferences (e.g. mouse speed, time and date/timezone, etc).

[EDIT]

Since we've established it works in Safe Mode, this means we've eliminated both the possibility of a network/router issue or a hardware issue. This is good, because it must be related to some sort of 'software' or 'data' issue. There is a remote possibility it will now work when started up normally, as booting in Safe Mode will have cleared some data.

If it doesn't, as another test, try creating another User Account and testing that. To do this, follow these steps:

  1. Go to System Preferences
  2. Click on Users & Groups
  3. Click on the + sign at bottom left (you may need to unlock the padlock before you can make changes)
  4. In your Login Options turn off Automatic Login and also ensure you display your login window as a list of users
  5. Exit System Preferences
  6. Shutdown your computer
  7. Reboot your computer and then login by selecting the User you just created
  8. Try connecting to WiFi

Please report back on the outcome.

  • Which is control button? – Zafar Saleem Nov 14 '16 at 23:05
  • It may be Ctrl on your keyboard. – Monomeeth Nov 14 '16 at 23:07
  • Tried both but still e same issue :( – Zafar Saleem Nov 14 '16 at 23:12
  • 1
    Have you got an iPhone or other device from which you can share a personal hotspot from? If so it'd be good to do that and see if you can connect to that from the MacBook Air. Basically we need to identify if this is a problem specific to your WiFi network/router setup or not. – Monomeeth Nov 14 '16 at 23:19
  • I just went to Starbucks and I had the same issue there. – Zafar Saleem Nov 14 '16 at 23:41

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .