0

Yesterday everything worked fine. But tonight, I'm unable to access particularly a few particular websites on all the imacs, mbp and even iphones at home. Weirdly enough, a quick 4G access via my iphones show the sites are accessible, but when i get back on the home network (via wifi / ethernet), it becomes unavailable with these errors:

  • ERR_NAME_NOT_RESOLVED

  • ERR_NETWORK_CHANGED

  • "...connection interrupted"

  • "This site can’t be reached.."

I've done all these tonight, but to no avail -- all on separate occasions on all imacs/mbp/iphone where possible:

  • cleared all cache, cookies and whatnots from google chrome..

  • updated osx to latest ElCapitan 10.11.6

  • restarted fibre modem, restarted router, restarted all computers/gadgets

  • tried sudo flushing my dns/mdns via terminal, but instead of receiving "say flushed" i got a "discoveryutil: command not found"

  • called the websites' web host techsupport and they're able to access the sites just fine.

& the best part about all this? Other websites work just fine. Only the few particular websites only. I'm bummed. Any pointers would be most grateful here.

IMHO, it's my router's DNS that's interrupting these few particular web addresses, but I am out of my wits to solve this. Heeeeeeelp~

Here's the particular site that can't be reached: enter image description here (www.mtggoldfish.com)

  • What do you get when you issue the command host www.mtggoldfish.com in Terminal? What about traceroute www.mtggoldfish.com? Also to flush your DNS cache, issue the command sudo dscacheutil -flushcache;sudo killall -HUP mDNSResponder;say cache flushed discoveryutil isn't used from 10.4 onwards – Allan Nov 14 '16 at 16:07
  • The host command doesn't use the same libraries that the system uses- it's better to use dig to check DNS resolution. For example dig @192.168.1.1 www.mtggoldfish.com (or whatever your DNS server's IP Address is). – MacManager Nov 15 '16 at 15:48
1

The very first thing to have tried would have been to change from your provider's DNS servers to a known public one.

Google is one of the most commonly known - also the numbers are easiest to remember

System Prefs > Network > [currently used] > Advanced... > DNS

The number currently in there will be the one assigned by your DHCP server, i.e. your router, so you don't really need to remember it, but write it down if you wish.

Hit the - button to remove it.
Hit the + button & add 8.8.8.8
repeat & add 8.8.4.4 OK
Apply

Reboot & test.

DNS issues usually sort themselves out in a day or two so if it works, keep it for a while, then swap back to your ISP's servers. You should be able to do that by simply removing both the Google servers & hitting OK, Apply. It will find the right one from DHCP.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .