1

I don't know why, but the ² and < are inverted on my external keyboard.

The ² is right after the left shift, where it's written "<", and the < is at the top of the tab key, where it's written "²" ...

Any idea why, and how I can fix that?

Thank you.

  • No such problem with your internal keyboard? – Tom Gewecke Nov 14 '16 at 18:44
2

I've got the same problem on an external Italian Keyboard, as said in the comments by Tom Gewecke the problem was Karabiner.

I want to maintain Karabiner for one of the two keyboards so I've done a "simple modification":

enter image description here

You can do the same with your inverted keys.

Another solution of the problem is disable Karabiner for a specific Keyboard:

enter image description here

1

You should give use more information about your external keyboard mapping. Your are only talking about 2 specific keys. That special keys can have different location with respect to your keyboard layout (and brand).

I would say that you have an AZERTY based mapping but where ² and < are inverted : AZERTY MAPPING

Solution on macOS 10.12

The best way is:

  • go in System preferences > keyboard.
  • click Input Sources tab (4th tab on macOS if you're OS is not in English).
  • then click on the "+" button at the bottom left of the window for adding a new layout.
  • browse the AZERTY mapping and try to find which one corresponds to yours.
  • tick "Show input in the menu bar" (bottom of the window, first option), it let you see you current mapping in your OS menu bar. You should see appear here a country flag or "ABC" or "ABC - AZERTY" or something else depending of your chosen layouts. enter image description here enter image description here

If your external keyboard has an unusual mapping, you have to try manually several kinds of layouts (ex: french/canadian french/swiss french).

  • Select the new added layout in the menu bar,
  • open a text editor to try if your software mapping corresponds to your physical mapping.
  • You should find the good one easily after few attempts.

If you can't find it

  1. A straightforward solution (if physical keys are similar) is to swap them physically.
  2. There is a way to write your own mapping configuration file on an Unix system, but we can talk about that only if nothing goes right.

Trick

An easy way for switching your layout whether you are using your laptop or ext. keyboard is to add a shortcut for making the switch:

  • go in System preferences > keyboard.
  • click "Shortcuts" tab (3rd tab).
  • select "Input Sources" in the left panel.
  • then add your special shortcut. enter image description here
  • Wow, That's a complete answer! I already mapped my keyboard to a specific AZERTY layout (sorry I forgot to mention it was azerty). All the keys are working correctly (including ! for example). Moreover, the ">" key, is at the right place (it's shift + <). So "<" and ">" should be on the same key, with "shift" to get ">" but oddly, on my layout, "<" and ">" are located on different key, but not on my keyboard. Is it clear? – Cyril N. Nov 15 '16 at 8:08
  • I know it's not clear, so I'll try another explanation : Based on the image of the keyboard layout from your answer, the ² is swapped with < but > is at the correct place. Is it clearer? :) – Cyril N. Nov 15 '16 at 8:08
  • Also, the first time I plugged the keyboard, Mac OS asked me to tell what was the key near left shift, so I entered <, but maybe I misread or maybe there was an error, and that caused the layout issue. If I could make Mac OS forget about the initial question, maybe my issue would be fixed? – Cyril N. Nov 15 '16 at 8:10
  • @CyrilN. Do you by chance have Karabiner Elements installed? – Tom Gewecke Nov 15 '16 at 18:17
  • @TomGewecke I did, but I installed after this issue, so it's not related :) – Cyril N. Nov 16 '16 at 7:56

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .