22

My MacBook Pro (mid 2014, Sierra 10.12.1) sometimes gets stuck after waking up after sleep. Some key seems to have stuck and keeps pressing into the password field forever, filling the password field and making me unable to type anything in. If I select all/delete, it refills again immediately, just like I'm pressing and holding a key on the keyboard. I've pressed all the keys as maybe OS thinks one is stuck, hoping that it will fix, but pressing all keys didn't work either. The only solution for me is to restart (and even if I press esc to sleep again, it immediately wakes up in a second as its "pressing" a key), if I close the lid, wait a minute, and open it again, it's still the same.

If I restart, I lose the work inside my apps. Usually nothing serious, but sometimes I've got apps open doing work in the background etc (e.g. batch image processing, neural net training, or any stuff that I can't save properly until the end) and they are all gone. This happens rarely, but when it happens, it causes me to lose data.

Why would this happen and how can I prevent this?

  • Can you try the following and report back on how each goes? (1) What happens if you connect an external Keyboard? (2) Does starting in Safe Mode display the same behaviour? (To start in safe mode hold down the shift key while you boot up the computer). (3) Does a hardware test report anything (to do this hold down the D key while booting up the computer). – Monomeeth Nov 14 '16 at 8:00
  • @Monomeeth 1) I don't have an external keyboard (and I don't know anyone who has one), but I had just plugged in my Bluetooth earbuds for charging into the USB port before waking it up, if it makes any sense. 2) Well, because this problem occurs rarely and goes away after a restart, I can't really test that. 3) I'll have a look at hardware test soon, maybe that will catch something, but again, I doubt it as my computer (and keyboard) works perfectly otherwise. – Can Poyrazoğlu Nov 14 '16 at 8:03
  • In that case, it'd definitely be worth resetting your SMC. Also for good measure, you could reset your NVRAM as well. – Monomeeth Nov 14 '16 at 8:06
  • 2
    maybe its correlated with the installation of the software Karabiner (Key Remapping). it occurs at my pc and a colleague pc after the usage of Karabiner (though a great software!) just a suggestion... – Ander Alex Apr 3 at 6:57
  • This happened to me after the computer was on sleep for a while. I confirm that I have Karabiner installed and also had my bluetooth on. Restarting the computer temporarily fixed the issue. I will remove the Karabiner app and see how it goes. – Doug May 12 at 19:37
8

The solution for me was from https://discussions.apple.com/thread/3450678

I turned off my bluetooth and it went away. There's definitely some issue with bluetooth and other devices.

  • 3
    This is not a solution, this is a workaround. Many people (including me) use Bluetooth for many things and it's not an option to turn it off. – Can Poyrazoğlu Aug 9 '18 at 17:54
  • 1
    This might be helpful for those who rarely use bluetooth. However in my case, I had to use a bluetooth keyboard because of a stuck key on my laptop. I did start having this problem since leaving bluetooth on, so this is a helpful answer in any case. – lacostenycoder Mar 7 at 12:31
4

I found this question from my phone while experiencing the same problem (High Sierra). I have no bluetooth keyboard, just the laptop by itself and I had tried pressing all the keys individually (ruling out physical stickiness).

I was able to solve the problem by selecting "switch user". After selecting myself from the list of users, it switched me back to the login screen and the repeating key abruptly stopped (it entered 2 characters in the password field and that was it).

No shutdown was required. I'm not sure if this is an expected solution to the problem or if I just got lucky. Also, I'm not sure whether this workaround was enabled by having multiple accounts on the machine (such that "switch user" is a valid action in the first place). I'm also not sure if (as a distant possibility) the fix was related to my having to move and click the trackpad a bit.

But it worked, and hopefully it will work for you too.

  • how do you get to the "switch user" from the MacOS login screen if you've already been logged in but you put your machine to sleep? – lacostenycoder Mar 7 at 12:28
  • For me it's right there at the bottom of the screen, in all of these cases I was already logged in and the laptop was previously asleep – Ian Mar 7 at 15:49
  • What version of MacOS are you on? – lacostenycoder Mar 7 at 17:23
  • High Sierra, I updated my answer – Ian Mar 8 at 12:05
  • 1
    This worked for me – in my case it was the Backspace key that was stuck, therefore not adding characters put deleting any input. I think this is a software bug somewhere. I too have Karabiner installed. – Winterflags Apr 3 at 10:48
3

Have you tried resetting your computer's System Management Controller (SMC)?

For your particular MacBook Pro, here’s what you do:

  1. Shut down your computer
  2. Keep the MagSafe adapter (power cable) plugged in.
  3. Press at the same time shiftoptioncontrol (on the left side of the keyboard) and the power button
  4. Let go
  5. Turn your computer back on with the power button.

Also, another thing worth doing is resetting your NVRAM.

To reset your NVRAM do this:

  1. Shut down your machine. Yes, a full shut down, not just logging out.
  2. Press the power button and then press the commandoptionpr keys. You have to make sure you press these keys before the gray screen appears or it won’t work.
  3. Hold those keys down until your Mac reboots again and you here the startup chime.
  4. Let go of the keys and let your Mac reboot normally.

Note: When you log back in you may need to readjust some of your system preferences (e.g. mouse speed, time and date/timezone, etc).

  • 2
    Original question clearly asks for a solution without shutting down the computer. – Mihai Alexandru Bîrsan Nov 1 '18 at 7:06
  • 1
    @MihaiAlexandruBîrsan This solution is proposed to fix an ongoing intermittent problem. If the user is stuck anyway, there is NO OTHER choice to get past the login screen without a shutdown. I'm experiencing the same problem – lacostenycoder Mar 7 at 12:26
  • If this is an ongoing intermittent problem, how does one know that the NVRAM reset is what actually fixes it? – Ian Mar 11 at 20:28
  • @Ian Troubleshooting is often a process of elimination and can require a fair bit of patience, especially in the case of intermittent issues. If there's nothing a user knows they can do that would normally bring on the issue, then the only certainty is just to wait. If the issue doesn't happen again within the timeframe it would've normally, then you know it's been fixed. – Monomeeth Mar 11 at 21:31
  • In other words, "I don't know". At best, this answer is a post hoc fallacy. – Ian Mar 12 at 2:18
3

I had EXACTLY this problem - and the solution made me feel a bit stupid in the end. I had a bluetooth keyboard stored in a bag a few meters away, which must have had a key pressed.

Funny thing is it only repeated on the login screen?

But pulling it out the bag (or turning off bluetooth) sorted it straight away.

3

As others have mentioned, a similar issue has been reported on the Karabiner-Elements GitHub page. Seems like one work-around is to turn off key repeat entirely (like this):

Keyboard dialog

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .