0

I've been having trouble sending messages (SMS and iMessage) from my Mac for a week or so now. I'm not sure if it exactly correlates with my upgrading to Sierra (10.12.1) but I have a suspicion that it's related to that.

Everything used to work flawlessly but now I can't send from my Mac. New messages that I receive appear on my Mac and iPhone (it's a 6 running 10.0.2) just fine. And new messages I send from my phone also appear on my Mac just fine too.

The below screenshot shows what happens when I click the (!) icon.

after clicking on "!"

1

I have had a similar problem in the past when upgrading OS. The easiest way to fix it I found was to disable iMessage on the faulty machine and then re-enable it.

To do this:

Messages > Preferences > Accounts > Click your iMessage account > uncheck "enable this account" > sign out > restart Messages > sign back in.

You may need to follow the steps above to recheck the "enable this account" box.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .