2

I've got a problem that while installing El Capitan from USB Installer it says "copy of software is corrupted etc..etc". Actually I downloaded the copy of El Capitan from another Mac and then I created "El Capitan installer from my own Mac with terminal process and when I try to install it it says the above message "copy of software is corrupted etc..etc". So tell me please anyone what happened and if it's date fault, then what date I should set because I didn't download El Capitan on the Mac on which I want to install it.

Please can anyone help me to sort out this problem??

  • It sounds like the installer may not have been copied over correctly. Can you create the USB installer on the Mac where you downloaded it? – Allan Nov 13 '16 at 11:22
1

You can try the following:

Go to System Preferences and manually change the date to January 1st 2016. More specifically, deselect Set date and time automatically and then manually enter the date and click Save.

After doing this, double click on the El Capitan installer and follow the prompts to install the software.

If you run into problems, a couple of additional things you can try are:

  1. Disconnect from the internet before manually changing the date and stay disconnected until you've done the installation
  2. Copy the installer onto the hard drive rather than running it from the USB

Let me know how you go.

  • I'm really thankfull to your work and I appreciate you're giving me your precious time. Its gonna work 100% fine. I doesn't have words to give you respect thanks sir and hats off to you. – Saqib Mughal Nov 13 '16 at 12:17
  • Could you please explain why change the date works? What problem does it solve? – lhf Apr 24 '17 at 12:18
  • At the risk of oversimplifying things, one of the checks the system does to determine the validity of the installer is the date. If you're using a copy that was downloaded quite some time in the past, it'll fail. As the OP said they had downloaded the installer from another Mac, I figured that was the case here. Also, as the OP asked the question after macOS Sierra was released, El Capitan was not the latest OS, hence also increasing the likelihood the date was a problem. I picked 1 January 2016 as that was only 3 months since El Capitan was released and a date most likely to pass the check. – Monomeeth Apr 24 '17 at 12:47
0

I just wanted to to confirm that @Monomeeth is absolutely right. I tried what he said and it worked! Than you!!

Steps:

  1. Boot into USB with the macOS on it.
  2. Disconnect from Wi-Fi if connected. Just turn it off for now..
  3. Click Utilities tab, then Open Terminal.
  4. Type date 0101121216 (which sets date to Jan 1st 2016 12:12 PM)
  5. Type cd /Volumes/Image and do not press Return yet, Press Tab instead, then press Return.
  6. Type cd Inst, and again, press Tab then Return.
  7. Type cd Contents/MacOS/ and press Return this time.
  8. Type ./Ins press Tab then Return and the installer should pop up and go from there to install the OS.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .