0

Alright, so I just got my iMac back from the store and I login to it knowing my password was correct, later I was trying to download a JDK but a window pop up asking me for the password of the admin account. I proceeded to entered my password but it won't accept it, all it does is say that it's wrong although I typed the exact same password. I tried contacting many people that I know but it still isn't working. Is there anyone who can identify this problem for me? If so then please do tell me how to fix it.

  • Did you ask in the store? Maybe they needed to reset the admin password to get your iMac fixed. – nohillside Nov 12 '16 at 8:20
1

It has been a while since I have tried this so I assume it still works

  1. Turn off your Mac (choose Apple > Shut Down).
  2. Press the power button while holding down Command-R. The Mac will boot into Recovery mode.

  3. Select Disk Utility and press Continue.

  4. Choose Utilities > Terminal.
  5. Enter resetpassword (all one word, lowercase letters) and press Return.
  6. Select the volume containing the account (normally this will be your Main hard drive).
  7. Choose the account to change with Select the User Account.
  8. Enter a new password and re-enter it into the password fields.
  9. Enter a new password hint related to the password & click Save.
  10. A warning will appear that the password has changed, but not the Keychain Password. Click OK.
  11. Click Apple > Shut Down.
  12. Now start up the Mac. You can login using the new password.

Or you could google "reset mac password" and follow the instructions I found and pasted in above.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .