2

I have a 2015 Macbook pro, which I bought about 3 months ago.

Some days ago, when I was using it, and connected it to my house's wifi network, everyone's internet connection suddenly dropped (as in they couldn't load anything, but wifi was intact). It didn't just happen in my house, so it makes me think something is wrong with my Mac.

If it helps, it's running Sierra.

I found out that this has happened to other people: http://www.mac-forums.com/internet-networking-and-wireless/183185-macbook-airport-breaks-internet-connection-entire-network.html

But nothing there was helpful.

Does anyone know how to fix this?

IMPORTANT EDIT: I believe I've found the cause of the problem: I'm using the program Parallels to run ubuntu, ** and if the program is not on, I can't lose all my internet connection.** I've uninstalled the program and now I'm on a bigger problem now: I still can't connect to internet and I can't reinstall the program... help pleas

  • "but nothing there was helpful." Specifically did you try the suggestion in the next to last post of that thread? – Tyson Nov 11 '16 at 22:31
  • @Tyson Deletting those settings files? Yes, I tried that, and it didn't help. – csTroubled Nov 11 '16 at 22:42
  • Does your MacBook have a fixed IP address on the local network? – Toby Allen Nov 12 '16 at 16:43
  • @Toby Allen No, it doesn't! – csTroubled Nov 21 '16 at 21:52
  • Please add your findings as an answer and your new question in a separate post. Thanks! – Jaime Santa Cruz Nov 22 '16 at 1:19
1

If I were you, I would backup all your important files, reformat the disk and reinstall the macOS unless you would have a better clue of what the problem is. It might be something as simple as a corrupted preferences file or as difficult as a faulty hardware component. If you try this approach and you find out that everything is working as it should then at least you can exclude any hardware problem.

| improve this answer | |
  • I had the same issue on my 2019 MBP. Resetting SMC, NVRAM and wiping the whole disk clean and repartitioning it did not fix the issue. It seems that it all started with an SMC update in the latest Catalina update, so I hope Apple will fix the problem in a subsequent release. – Palle Feb 6 at 10:30

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .