I got a new SanDisk SSD for my MBP and can't get El Capitan installed. Whenever I try to partition the SSD from within Disk Utility of my bootable USB (or format it via Erase), the process gets stuck and reports either the same error as here or gets stuck at 50% as described here.

I tried the approaches of the replies in those posts. I created a bootable ubuntu USB and used gparted to format the SSD to gpt first and then to fat32, HSF+, Ext3 hoping that it would allow me to erase the SSD back in Disk Utility. None of these worked out. (Formatting with gparted works, but erasing with Disk Utility afterwards still doesn't)

Gparted from within ubuntu reports The primary GPT table is corrupt, but the backup appears OK, so that will be used and I remember I tried to fix it via Terminal. The same error still pops up whenever I start gparted so I guess I failed.

When I use gpt from within the El Capitan USB it shows me unable to open device '/dev/disk0': I/O error.

Trying to partition the disk via command line (diskutil partitionDisk ...) also gets stuck at 50% as described above.

These are only a few approaches I've tried and which I can remember. I've been googling for quite some time now and don't really know what else to try. I also don't know if this is a problem with my MBP/OS X or the SSD and if I just should return it and get another one. Sometimes when I reboot it happens that the SSD is not displayed/found when using Disk Utility.

I would really appreciate any help on this.

  • I should have been more specific and said formatting on Ubuntu via gparted works, but erasing the disk back on Disk Utility still doesn't work. Nov 11, 2016 at 9:49
  • Did you also try to delete your SSD in Recovery Mode an? How is your new new SanDisk connected?
    – howdytom
    Nov 11, 2016 at 10:22
  • I replaced my old SSD with the new SanDisk. (In case it's relevant: My old SSD got corrupted few days ago. Kept getting a folder with question mark when booting. Couldn't repair it with Disk Utility and other approaches so I gave up on it and returned it.) No I haven't before reading your comment. Tried it now. Disk Utility doesn't display the SSD. Not even after the 4th reboot into recovery mode. Nov 11, 2016 at 11:38
  • You may try to format your SanDisk SSD with a external USB connector, first. Your new SanDisk SSD should show up in Disk Utility as expected. If so, your MacBook HDD cable that connects the SSD to the logic board might be broken.
    – howdytom
    Nov 11, 2016 at 14:36
  • I thought about that too. I just ordered one and will try to format it from another MBP. Im sceptical regarding the broken HDD cable since I don't have any problems from within Ubuntu. There the SSD gets always displayed. Nonetheless, I appreciate your efforts and advice! Nov 11, 2016 at 14:45

1 Answer 1


in order to install ElCapitan, you have to format to GUID Partition Table, and Mac OS Extended (journaled), nothing else.

  • And how would I do that if Disk Utility keeps throwing errors? Is there any other way besides Disk Utility / diskutil partitionDisk Nov 11, 2016 at 13:46

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .