7

I did an update on my Macbook Retina 13" to the most recent version of Sierra OS X. The computer never gets past the Apple logo (black screen with a full progress bar).

I booted into Verbose Mode (command + v) and see that it is stuck at the following point:

SmartBattery: finished polling type 4

Every now and then it will add another line of text (same text) but it never moves beyond that point.

Any advice please! It is a real pain to keep restoring from my Time Machine backup!

  • Try booting in Safe Mode (hold Shift while booting) – Allan Nov 10 '16 at 13:43
  • Try booting without a battery – John Keates Nov 10 '16 at 15:34
  • With verbose mode, the last message is often not the true cause of the problem. Reboot in verbose mode, and post some pictures (with a camera) of the output. – Kisa Ayano Nov 22 '16 at 2:36
  • I got the same problem and resetting the SMC did not help. Before the polling, it says: busy timeout[1], (60s), kextd wait(1): *here about 4 lines with around 20 random characters each" – Motin Jan 23 '17 at 9:37
  • Is this for the update 10.12.2 ? If so, then an outline to a solution might be found here: discussions.apple.com/thread/7787207?start=0&tstart=0 Source: apfeltalk.de/community/threads/… – Motin Jan 23 '17 at 9:44
5

Had the same issue and found the solution here: https://discussions.apple.com/thread/7787207?start=0&tstart=0

Quotes:

Now that I look a bit more closely, the issue may be a corrupt .kext file as I get two busy timeout [x] (60s) kextd wait(1): messages with corrupt garbage characters listed just at the start of the infinite SmartBattery messages.

Not convinced the battery is really the issue as the machine will boot quite happily when using another boot disk or USB drive and the SmartBattery checks in those boot logs are really no different. To me it looks like the boot process has hung at the kextd and the endless SmartBattery messages are the OS just passing the time waiting for a response to the kextd daemon its never going to get.

Your (and my) problem is because auf a KEXT file which is not compatible to 10.12.2 - the software isn't clever enough to ignore this, so you have to do it yourself. There are some ways. I made it this way:
Start into Recovery HD, Open Terminal, write down:

mkdir /Volumes/"Macintosh HD"/kextbackup
cd /Volumes/"Macintosh HD"/System/Library/Extensions

look for .kext files which are not part of the normal system

mv KEXTNAME.kext /Volumes/"Macintosh HD"/kextbackup/

I removed the following and after this the system booted again.

Belcarra.USBLAN_netpart.kext
Belcarra.USBLAN_usbpart.kext
HuaweiDataCardDriver.kext
JMicronATA.kext
RemoteControl.USBLAN_usbpart.kext
UsbEthernetGadget.kext
USBExpressCardCantWake_Huawei.kext
vecLib.kext

Of course everybody has his own not compatible kext files in this folder. Actually you can't do anything wrong by just moving them to another place... But I would recommend you not to move any of the APPLE*.kext files and the IO*.kext files. Other files with not that normal names, I would move and try to start.... At the moment my Sound is not working.. So I moved one kext too much, but anyway... I can write this.. in Safari on my Macbook Pro Retina....

EDIT: This worked for me. Note that I also had no sound but got it back after moving back "vecLib.kext" (by again returning to recovery mode and moving it back from the kextbackup-folder), so try to keep that in place from the beginning :)

  • I only had 4 of the items in the list and removed 3 of them (except for vecLib.kext) and that fixed the issue. My Mac starts again! So no need to try to remove other kext files for me. – Dacker Jun 3 '17 at 15:35
  • 1
    This worked for me. I only had to move 2 ktext files: JMicronATA.kext and HuaweiDataCardDriver.kext -- BTW I've used Mac for 12 years and it's the first time mine died after an update. Apple are really going downhill! Really considering to stick to Linux. – Organic Jul 29 '17 at 16:39
  • 1
    My mac had apparently automatically initiated an upgrade to 10.12.6 and shut down (battery dead?), because it got stuck on the login progress bar when I tried to boot it after some shelf time yesterday. After following these instructions and removing two Huawei related drivers and booting normally, the upgrade continued with a progress bar and a "Finishing installation, around 12 minutes left" or similar message. After the installation finished, it was working normally. Even my previously open browser tabs were restored. – Fredrik Boström Sep 4 '17 at 19:45
  • I don't know whether this is a new thing but in my case, on MacOS 10.12, the kexts in /System/Library/Extensions looked just like essential core modules and removing them did nothing but cause an endless reboot loop. The juicy stuff - kexts installed by 3rd party apps and such - was in /Library/Extensions! In my case, removing an Epson kext that I had installed to print on my mother's printer did the trick. – Pekka 웃 yesterday
0

Someone in our office had this exact problem this morning. Managed to get it working again by resetting the SMC (System Management Controller).

Hope this helps someone else in the same situation.

To reset your SMC.

If the battery is nonremovable

  1. Shut down the Mac.
  2. Plug in the MagSafe or USB-C power adapter to a power source and to your Mac.
  3. Using the built-in keyboard, press Shift-Control-Option on the left side of the keyboard, then press the power button at the same time.
  4. Release all keys, then press the power button again to turn on your Mac

If the battery is removable

  1. Shut down the Mac.
  2. Disconnect the MagSafe power adapter from the Mac.
  3. Remove the battery. (Learn about removing the battery in MacBook and MacBook Pro computers.)
  4. Press and hold the power button for 5 seconds. Reconnect the battery and MagSafe power adapter. Press the power button to turn on the Mac. The LED on MagSafe power adapters might change states or temporarily turn off when you reset the SMC.

(SMC instructions from https://support.apple.com/en-gb/HT201295)

  • 1
    This did not help me, same situation as OP. Also tried resetting NVRAM and repairing the internal hd. – Motin Jan 23 '17 at 9:35
  • This didn't work for me. I even re-installed OSX from recovery and boot still failed. The accepted solution worked. – Organic Jul 29 '17 at 16:41
-2

Recover from backup only with apps and user data solve the problem.

  • 1
    This will probably "solve" it since you will not restore the incompatible kext-files in the new system, but it is overkill and should only be used as a last resort or in case there is noone around that can use the terminal and follow instructions. – Motin Jan 23 '17 at 10:06

You must log in to answer this question.

protected by Community Jan 2 '17 at 18:51

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .