7

iPhone 7
iOS 10.1.1
Gmail 5.0.3
Chrome 54.0.2840.91

When trying to open a link directly within the gmail app, it opens in safari instead of chrome. This used work just fine until the latest update of gmail.

I looked in the gmail settings under google apps, to use the app instead of the browser. There is no option for Chrome where I imagine it should be.

I can't find any other option to make chrome the default browser instead of safari.

Help?

UPDATE: As of 11/26/2016, the problem seems to have been fixed. Links from my gmail app open up in chrome again.

  • Regarding your "update" that it is now fixed... you should probably add that as an answer (and accept it). Incidentally, under the "Google Apps" section in the Gmail app settings you can now control which app opens (Chrome or Safari etc.) I'm using Gmail 5.0.6 (on iOS 9.3.4) and it works OK (again). – MrWhite Dec 11 '16 at 1:01
10

iOS 10 isn't the problem - the "old" gmail app still opened links in chrome well after updating to iOS 10. This didn't become an issue until updating to Gmail's version 5 that this became an issue.

6

I'm not sure if the following procedure is exactly what you tried, or if you did something differently – but maybe this helps anyways:

  • Run the Gmail app.
  • Click the little menu icon in the upper left (three parallel stripes).
  • Click the Settings gear icon.
  • Click "Google Apps" near the bottom (you may have to scroll down).
  • Turn "Chrome" on or off at your preference. On means links will go to Chrome; off means they'll go to Safari.

…as described here.

Update: sorry to say, but it looks like this is actually no longer possible in iOS 10: "iOS 10 won't let you select default apps for third-party apps that handle email, calendar, web browsing, …." (from here)

  • That is what I tried. There is no slider for Chrome. – FrancisJohn Nov 10 '16 at 13:06
  • Sorry, but I was actually describing how it was done before iOS10 – this seems to be no longer possible in iOS10 (?!) – tillinberlin Nov 10 '16 at 13:12
  • 2
    Woooooow..... that is inanely obnoxious. – FrancisJohn Nov 10 '16 at 13:14
  • 2
    This isn't an iOS 10 problem, it seems to be a problem with the updated Gmail app. I'm still on iOS 9.3.4, but I've updated the Gmail app to v5.0.3 and now all links open in Safari (previously they did open in Chrome) and there is no "(Google) Chrome" option in the Google Apps section of the Gmail app. (?!) EDIT: Just updated to v5.0.4 and still the same problem. – MrWhite Nov 11 '16 at 16:12
  • Maybe it's centralised in Settings -> Google Apps? I don't have an iPhone so I can't confirm, I'm just interested in whether this is possible – Conan Nov 14 '16 at 15:02
1

Problem resolved itself by as early as 11/26/2016.

Gmail: 5.0.7 Chrome: 55.0.2883.79 iOS: 10.1.1

You must log in to answer this question.

protected by Community Nov 16 '16 at 2:03

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .