1

I'm having a lot of troubles getting Apple Remote Desktop to work in Sierra.

Downloading the client (version 3.8.5) gives me the error:

Remote Desktop Client Update can't be installed on this disk. This update required Mac OS X 10.10.5 or later.


When I try to generate the installer on Sierra (a Mac Mini), I get the error:

An unexpected error occurred: the required components were not found.

The Application appears to be installed incorrectly.


I have the feeling that Apple Remote Desktop is on it's way out, but is there an alternative to use? Preferably one that doesn't have a monthly cost (per device)

2

Pascal a.k.a. xvi answered this question about ARD not working on OS X Sierra. My macs with OS X Sierra have the symptom of ARD not working sometimes and other times ARD starts up just fine. Here is the fix that worked for me: https://discussions.apple.com/thread/7733349

Apple Remote Desktop doesn't start after sierra update. We tried with same problems on different client (macbook pro, imac and mac pro)

The workaround I have found is this (requires to be administrator):

Launch Terminal, then type:

 sudo pkill -u -2 ARDAgent

and type your password as requested. Then, Remote Desktop.app will launch (or, if launched and hung, its main window will appear).

  • Thanks, it worked after many other things didn't! Just to clarify, this is a fix for ARDAgent even if the "Remote Desktop" app is not installed on a machine. – Nicholas Riley Mar 8 '17 at 23:51
1

The remote program is working well for me on Version 3.8 (380A95) on Sierra. The client you mention is so a Mac can be controlled by another computer, so perhaps you don't need that installation and can update only when App Store or softwareupdate -ad downloads a package to install.

If you want third party options - Screens app by Edovia is a pro quality software that I really appreciate and use side-by-side with ARD. They do different things better than the other.

  • I've just tried to add a computer (without installing the client software) and I get the error message: "X is running software that is too old to support this feature. It must be running Apple Remote Desktop Client v3.3.1 or later in order to provide the list of Administrator Computers which manage it". Is there something I need to do to allow remote desktop to manage it? – Garion Nov 10 '16 at 2:48

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .