-1

I am trying to install Homebrew on macOS Sierra 10.12.1 . All latest macOS and Xcode 8 updates have been installed.

I tried several commands in terminal:

ruby -e “$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install)”

and

ruby -e "$(/usr/bin/curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install)"

In the first time I pressed Enter and then provide my password to install it, but I did not get anything that shows if Homebrew is installed successfully.

Tried again and this is what I get:

hanaas-MacBook-Pro:~ hanaaalshareef$ ruby -e "$(/usr/bin/curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install)"
==> This script will install:
/usr/local/bin/brew
/usr/local/share/doc/homebrew
/usr/local/share/man/man1/brew.1
/usr/local/share/zsh/site-functions/_brew
/usr/local/etc/bash_completion.d/brew
/usr/local/Homebrew

Press RETURN to continue or any other key to abort
==> Downloading and installing Homebrew...
hanaas-MacBook-Pro:~ hanaaalshareef$ 

then I kept waiting and waiting and nothing happened.

I tried this command :

hanaas-MacBook-Pro:~ hanaaalshareef$ brew doctor
-bash: brew: command not found

I found this in local:

hanaas-MacBook-Pro:/ hanaaalshareef$ cd /usr/local/
hanaas-MacBook-Pro:local hanaaalshareef$ ls
Cellar              mysql
Frameworks          mysql-5.5.29-osx10.6-x86_64
apache-maven        opt
bin             sbin
etc             share
homebrew            texlive
include             var
lib
hanaas-MacBook-Pro:local hanaaalshareef$ cd /usr/local/homebrew/
hanaas-MacBook-Pro:homebrew hanaaalshareef$ ls
CODEOFCONDUCT.md    Library         bin
LICENSE.txt     README.md  share

Any suggestions how to solve this problem? I really need help with this

  • 3
    Check if you have /usr/local/bin/ in your PATH var. (just echo $PATH in terminal). – Vagner Nov 9 '16 at 11:55
-3

Same problem. For me this working fine:

https://coolestguidesontheplanet.com/installing-homebrew-on-macos-sierra-package-manager-for-unix-apps/

  • 1
    link-only answer. – klanomath Nov 9 '16 at 22:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .