6

I'm using a proxy script to connect to the Internet. I've set it, system wide, in :

System preferences -> Network -> Advanced... ->Proxies -> Automatic Proxy Configuration

and it works well.

I've also set it in Firefox

Preferences... -> Advanced -> Network -> Connection -> Settings -> Automatic Proxy Configuration URL

and it works well too.

In Safari, which use the system proxy configuration everything works well.

BUT in chrome Version 54.0.2840.87 (64-bit), which should use also the system proxy configuration everything is very slow and I always see, in the status bar, the message :

Resolving host in proxy script...

I've found the following thread about Proxy Pac and Sierra but it doesn't help.

Any idea?

P.S. I'm using macOS 10.12.1

  • Hi, did you found a solution ? I get the same problem since i migrated to sierra .... – wawanopoulos Nov 16 '16 at 9:23
  • For now my solution is to use Firefox... – Ortomala Lokni Nov 16 '16 at 10:54
  • Same problem here, and I had to use Firefox for now as well.. – Ali Jan 5 '17 at 13:26
9

I was experiencing this issue while using a corporate VPN from Chrome on a Mac. I resolved it by:

  1. Getting the full hostname from running the command hostname
  2. Opening up /etc/hosts in an editor, with write permissions, e.g. sudo vi /etc/hosts
  3. Adding the name of the machine to localhost, e.g.

    127.0.0.1   localhost Eamons-MacBook-Pro.local
    
  4. Saving /etc/hosts

Caveat: It is possible that /etc/hosts may be updated by the system during reboots and upgrades, and changes could be lost.

  • Curious as to why this works. I don't have my hostname aliased to 127.0.0.1 but I can still ping it. – Kyle Chadha Jul 18 '17 at 15:59
4

I had a similar problem but it was only happening when using Chrome over a VPN connection, Safari was ok. Looking at the Chrome events using chrome://net-internals/#events I noticed that I had HOST_RESOLVER_IMPL_JOB events that were trying to connect to My-MacBook-Pro.local but failing. I could ping My-MacBook-Pro but not My-MacBook-Pro.local.

I resolved it by going to System Preferences -> Sharing and turning on one of the services (Printer Sharing, File Sharing etc). Once I had done that I could ping My-MacBook-Pro.local and Chrome started responding properly.

0

We had the issue due to having 4-5 old old DNS servers manually entered in the mac's network settings. The machine was trying to contact each of these and timing out. Once we cleaned up DNS the problem went away.

  • I've no manually entered DNS. DNS servers are obtained through corporate DHCP and I'm pretty sure it's correctly configured. – Ortomala Lokni Jan 7 '17 at 17:37
  • We used dig to prove to ourselves that the DNS servers we were trying to use were really really slow. dig <same website> from a mac terminal window and see if it's slow. that was basically our issue. – dny238 Jan 9 '17 at 17:13

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .