3

I have a MacBook Air running OSX El Capitan, version 10.11.6. I downloaded XQuartz 2.7.11, but when the program that uses it launches it (or I double-click it in the Utilities folder), XQuartz begins an infinite loop in which the logo appears briefly in the dock, then an "Xquartz quit unexpectedly" window pops up. There's also a crash report, but I can't make heads or tails of it and it's too long to fit within the character limits here.

What seems to be a bit more helpful is what appears in the logs recommended here, which records the following over and over:

Nov  8 22:17:19 XXXXX-MacBook-Air org.macosforge.xquartz.startx[18311]: syntax error
Nov  8 22:17:08 XXXXX-MacBook-Air org.macosforge.xquartz.startx[18150]: expr: syntax error
Nov  8 22:17:08 XXXXX-MacBook-Air org.macosforge.xquartz.startx[18150]: xauth:  file /Users/XXXXX/.serverauth.18151 does not exist
Nov  8 22:17:08 XXXXX-MacBook-Air org.macosforge.xquartz.X11.stub[18295]: Xquartz: Unable to locate waiting server: org.macosforge.xquartz.X11
Nov  8 22:17:08 XXXXX-MacBook-Air org.macosforge.xquartz.X11.stub[18296]: Xquartz: Starting X server: /Applications/Utilities/XQuartz.app/Contents/MacOS/X11 --listenonly
Nov  8 22:17:08 XXXXX-MacBook-Air org.macosforge.xquartz.X11.stub[18295]: Xquartz: start_x11_server: (ipc/mig) server died
Nov  8 22:17:10 XXXXX-MacBook-Air org.macosforge.xquartz.startx[18150]: /opt/X11/bin/xinit: giving up
Nov  8 22:17:10 XXXXX-MacBook-Air org.macosforge.xquartz.startx[18150]: /opt/X11/bin/xinit: unable to connect to X server: Connection refused
Nov  8 22:17:10 XXXXX-MacBook-Air org.macosforge.xquartz.startx[18150]: /opt/X11/bin/xinit: server error
Nov  8 22:17:10 XXXXX-MacBook-Air com.apple.xpc.launchd[1] (org.macosforge.xquartz.startx[18150]): FairPlay decryption failed on binary.
Nov  8 22:17:10 XXXXX-MacBook-Air com.apple.xpc.launchd[1] (org.macosforge.xquartz.startx): Service only ran for 2 seconds. Pushing respawn out by 8 seconds.

I get that there's apparently a syntax error, but why would there be, and what am I expected to do about it?

I found this post, but it's from four years ago and is about Mountain Lion. Nevertheless, I attempted to do what solved the problem then -- moving ~/.xinitrc.d out of the way -- but I cannot find an .xinitrc.d on my system. Same with the other suggestion about /sw/bin/init.sh. I also moved every rc/profile file into a different folder, to no effect.

I also completely uninstalled and reinstalled XQuartz, but it only resulted in the same problem.

I'm tearing my hair out. Any suggestions?

  • 1
    Does this line Unable to locate waiting server: org.macosforge.xquartz.X11 mean that it can't connect with an authentication server so it's just quitting? – fsb Nov 9 '16 at 16:46
  • Probably? But if so, how would I fix that? – user124384 Nov 9 '16 at 17:01
  • 1
    I don't know. Assuming your internet connection is ok then either the URL is bad, your system is preventing it, or the server isn't responding. I'm no expert on this, and maybe someone else can tell if this is really an issue or not, but it does seem strange that it says unable to connect to X server: Connection refused. Maybe contact XQuartz for support? – fsb Nov 9 '16 at 17:04
  • Is it seriously trying to connect to a non-local server? That seems weird to me. But yeah guess I'll try xquartz directly. – user124384 Nov 9 '16 at 18:52

You must log in to answer this question.

Browse other questions tagged .