0

Below is the 2 screenshot that I have tried after searching on so many places on net, but nothing worked for me until now.

First one is via using DiskUtil :

enter image description here

And second one via terminal :

enter image description here

Both the method is having issue and unable to format the sdcard, could anybody please help this out.

Highly appreciated your help in advance thanks.

Update the current snapshot of the memory card from disk utility : enter image description here

  • If it won't unmount, reboot the Mac. If it still won't unmount/format, throw it away. SD cards are just not reliable - I deal with hundreds of them for work & they're just not worth the effort once they start to fail. If there was a write error, the firmware is likely to have switched it to write-protect mode which is to all intents & purposes irreversible. – Tetsujin Nov 8 '16 at 18:12
  • Check if your SD card has small switch on its side for write protection. Probably it is switched on and therefore you cannot format it. – Denis Rasulev Nov 8 '16 at 18:13
  • Also check if you have anything opened from that SD card - any file and/or app. Just in case. – Denis Rasulev Nov 8 '16 at 18:19
1

I had a reluctant SD Card that reported "Resource Busy" whenever I tried to dd an image onto it even after unmounting it. My fix was to use the "Force" option for the diskutil unmount command:

diskutil unmountDisk force /dev/disk<# of the drive you want to unmount>

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .