1

Ok, i have asked this question two times in stackoverflow two times, here and here.

I haven't gotten an answer, but after rethinking the problem i think it may be because of files / folders permissions, ok this is what it is happening.

Environment: eclipse STS 3.8.2 which run over java 1.8 and the SO is macOs Sierra.

when i open the IDE for first time it creates a folder in my home user called .eclipse and inside a folder with the name org.springsource.sts_3.8.2.RELEASE_562342862_macosx_cocoa_x86_64. The IDE uses this folder to save configuration, plug-ins and so on, ok latter when i close the IDE and open it again, the IDE creates a new folder like the first but it changes the name like this org.springsource.sts_3.8.2.RELEASE_562342586_macosx_cocoa_x86_64 and saves the configuration there, so all the previous configuration it is lost.

This leads to have a fresh environment every time i open the IDE, so every plug-in installed it is lost. I have tried to copy and paste the content of one folder to another but the IDE ignores the files in there.

  • Hmm - do you think this is a bug in eclipse how it saves settings or a bug in how STS asks the editor to save config? Either way, this looks like a bug and not something you can configure your way out of. I wonder if you were to sym link the newer folder when you discover it so your settings "persist" – bmike Nov 8 '16 at 20:33
  • Hi, i tried the previous version and the behavior it is the same, which did not happened in other mac. – OJVM Nov 8 '16 at 21:03
1

I was also facing the same issue. To resolve it I did the following steps.

  1. Extract the tar/zip file anywhere you want.
  2. Drag the STS.app file to "Applications".
  3. Now you will see the STS application in launchpad also.
  4. Now you can start STS by clicking on this STS icon from launchpad/spotlight search.

It should resolve the issue.

  • Thank you, it worked, i also commented your answer in the others posts. here and here – OJVM Dec 5 '16 at 15:33

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .