0

I recently came across an adware on my Mac. I've uploaded a video on youtube. Pay attention to the very redirects! I used to have this on El Capitan as well, then I clean-installed Sierra. After about a month this is what I get: https://www.youtube.com/watch?v=bBcPDWpB3XA&feature=youtu.be

I've tried updating to the latest version of the OS which is 10.12.1 right now. I've tried Malware Bytes, MacScan and similar software; but they don't find anything.

I've tried resetting safari, used App Cleaner to delete all the related files. Also, no fix. I've tried changing my DNS servers and still no fix. There's no plugin or extension on my safari.

enter image description here

So, how can I get rid of this adware?

  • What is your question? Please see How to Ask for tips on asking good questions. – fsb Nov 8 '16 at 14:12
  • @fsb I fixed it by adding a "How to remove..." to the title of the question. Thanks. – Milad Nov 8 '16 at 14:26
  • I have the exact same problem as well. I run a macOS Sierra 10.12.6. – Zlatko Aug 8 '17 at 0:48
  • @Zlatko for me it got fixed automatically after updates. I suggest a clean install and always update to the latest version as soon as they become available. Haven't had a problem since. – Milad Aug 8 '17 at 15:51
1

Backup your data and let Malwarebytes do the job.

  • it's not possible. I contacted MalwareBytes support and they said they don't provide malware removal for web browsers. – Milad Dec 10 '16 at 17:31
  • That doesn't make sense and they must have misunderstood the question, but malwarebytes is a utility whose sole purpose is removing malware/adware on Macs. It is the correct answer to your question. – l008com Mar 31 '18 at 3:55
0

It would be best to run Malwarebytes for Mac, but if you're looking to remove adware from the browser, the following Mac App Store app seems to offer adware removal for browsers.

Check it out here — Adware Doctor:Anti Malware & Ad

If you don't want to pay for the app, I would suggest you check your browser extensions to make sure nothing unexpected is installed.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .