0

I'm trying to update my iPhone 5S to iOS 10.1.1 (current: iOS 9.3.2). I downloaded the ipsw through iTunes and tried updating my iPhone.
However, I am getting error code 45 after iTunes says "extracting software".
My iTunes is up-to-date, and so is my Mac. I did check Apple's error code page but 45 isn't listed there.

Any idea what I could do w/o restoring my iPhone? (I forgot to back it up before updating)

1

Take a look at The iPhone Wiki's website where it states that Error 45 is:

Same with Error 6, in terms of resizing partition issue. But this may occur at the very beginning of restore process.



Whereas on Error 6 they write:

  • Not enter the downgrading mode, change USB port (the back one of chassis is better) and restart computer.
  • Unable to resize partition due to full storage problem at final stage of updating firmware. The error may be bypassed (restart and do exit recovery) but you probably need to re-update it one more time.
  • Rebooting my Mac and using different usb ports did not change anything. – LinusGeffarth Nov 8 '16 at 8:29
  • @LinusG. the issue states that there might be an issue with resizing the partition, could it be that you're running short on disk space or perhaps you have some permissions issue on your partition? – Pinchus G. Nov 8 '16 at 9:49
  • I indeed had few space left on the iPhone. Problem only is, now I can't free up any since it's in recovery mode and I can't seem to get it out there doing hard reset or anything. – LinusGeffarth Nov 8 '16 at 9:50
-1

Error 45 could be done by restore, if you are updating so it will give you the same error 45, so restore your phone.

You must log in to answer this question.

protected by Community Jun 2 '17 at 1:49

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .