1

The iOS calendar app doesn't sync iCloud calendars anymore.

Example: I add calendar events on a mac, which uses the same iCloud calendars, and add a notification for in 5 minutes. In the past, my iPhone would notify me about this event though the set notification. This doesn't happen anymore as I now have to manually open the calendar app on my iPhone in order to make it sync the calendar events.

How can I fix this?

  • 1
    Check this: Settings > Calendars > Accounts > Fetch New Data set on Push? Is the battery icon yellow (thus Low Power Mode on)? And is the Background App Refresh toggle off? It appears that the last one only affects third party apps, but I'd check it to be sure. – Jaime Santa Cruz Nov 7 '16 at 11:21
  • Update: Actually, when I clicked on: Settings > Calendars > Accounts > Fetch New Data > <My Account> and here on "Push". Now this works. Only selecting it as you described above, like I did before, isn't to sufficient. – Niko Nov 8 '16 at 12:50
1

So the actual solution was to go to:

Settings > Calendars > Accounts > Fetch New Data > [My Account name] >and here tap on "Push".

Selecting "Push" in Settings > Calendars > Accounts > Fetch New Data was not enough.

  • I've never seen Settings -> Calendar -> Accounts. I only see Settings -> Mail, Contacts, Calendars -> Accounts -> iCloud ... then it's a dead end for Calendar settings. – MDJCM Aug 3 '17 at 14:28
  • EDIT: Ok so its Settings -> Mail, Contacts, Calendars -> Fetch New Data -> Choose account here -> Then set Push – MDJCM Aug 3 '17 at 14:34
  • I can see it. Perhaps the translation is different in german (which my iOS is set to). Edit: Well maybe I translated Fetch New Data wrong from german, here it says Datenabgleich. – Niko Aug 3 '17 at 14:38
  • @MDJCM: On my iPhone (iOS 11.2.1), choosing "Mail, Contact, Calendars" is not an option. In my case, I need to select "Accounts & Passwords" and then set my push/fetch options. I created a new answer that describes how things look on my end. I wonder if a difference in iOS versions is affecting the series of steps. – EJ Mak Jan 12 '18 at 19:19
0

You will need to set your calendar account(s) to “push” updates to your iOS device, or “fetch” updates on a regular interval.

The following steps apply to iOS 11.2.1 for iPhone. If these instructions don’t work for you and you’re running the same or a later version, please edit or comment as appropriate.

1. Open your Settings app.

step 1

2. Scroll to “Accounts & Passwords.” Don’t select “Calendars.” (Not intuitive, I know.)

step 2

  1. In the new screen, scroll all the way down to “Fetch New Data.” Don’t choose “iCloud” or any other account yet. (Still not intuitive, right?!)

step 3a step 3b

  1. In this screen, choose the desired account for the calendar(s) that you want to affect and set it to “Push” or “Fetch.” You may also want to turn on/off “Push” at the top, depending on your needs. In this case, I have “Push” turned on at the top and set iCloud to take advantage of the option. All others are set to manually check the accounts when I run the app.

step 4

  • Boo to the Apple interface designers for making this process so challenging! – EJ Mak Jan 12 '18 at 18:54
0

I found the fix!

  1. Goto: Settings > Accounts and Passwords > Fetch New Data (Visible below the list of accounts)
  2. Enable Push (on the top)
  3. At the bottom of the page you will find Fetch description which by default would be set to Automatic. Now in this mode, the phone fetches data in the background only when on Power and WiFi. Therefore **change the choice from Automatic to Hourly (**or 30 mins or 60 mins)
  4. Now on the same page open the Calendar account which you want to sync in background and select Fetch (and not Manual)
  5. Done!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .