1

I have about a few hundred of epubs that I’d regularly been syncing on my iOS devices until I’ve updated to Sierra a few days ago, when suddenly only a few books showed up in iTunes.

I tried turning iCloud support for iBooks on/off as some people have suggested on other forums but it didn’t help.

How can I make all epubs from iBooks to show up in iTunes?

1

OK, I’ve managed to solve this with the help of another guy from Apple Suport Forum.

Here’s what I did:

  1. I Quit the iTunes
  2. I opened iBooks
  3. I backed up my books and PDF’s from iBooks by dragging and holding alt copying them to a backup folder
  4. I deleted all of my books and PDF’s from iBooks
  5. I quit the iBooks
  6. I went to the Settings > iCloud > Options > iBooks and turned the iCloud support for iBooks off
  7. I went to the Library folder in Finder and located the nsurlsessiond folder via search
  8. I copied the folder to the backup folder, just in case
  9. I deleted the nsurlsessiond folder
  10. I shut the OS X down
  11. I turned the computer on
  12. I opened iBooks I moved my books and PDF’s from the backup folder to iBooks
  13. I turned the iCloud support for iBooks on (see the step 6)
  14. I opened iTunes
  15. Voilah! All of my books and PDF’s are there!
  16. I synced the books successfully to both iPad 3 and iPhone 6
  17. I checked the highlights, bookmarks, notes and the last page read and everything was properly syncing

Here’s the original forum post.

  • Thanks so much Sinisa - not only did this fix the issue of my iBook epubs & PDFs not showing in iTunes, BUT it also fixed an issue where my phone was not syncing with the Photos App on my Mac. Only difference for me is that under System Preferences > iCloud > .. I turned off all the Photo settings here, including those under iCloud > Options. Not sure if that was necessary or not. – Bastion Jul 20 '17 at 1:04
  • Awesome, great to hear it still works :) – Siniša Šašić Jul 20 '17 at 6:46
0

I tried toggling iCloud iBook syncing first and had some luck but it eventually got stuck again. While exploring alternatives to deleting the nsurlsessiond folder I discovered this solution. I suspect it works without first needing to toggle iBook syncing.

Navigate to iBooks Folder

  1. CMD+Space (Spotlight): "[name of a book in iBooks library]"
  2. Highlight book and press CMD+Enter or CMD+Double Click on book. If the book exists in multiple locations you can check for the correct location (".../Mobile Documents/iBooks/iBooks/...") by highlighting an item and holding CMD to display the path in the Spotlight status bar area at the bottom).

Remove and Re-add Stuck Files

  1. Move all items with the unsynced iCloud icon (dotted cloud) to another folder temporarily (e.g. Desktop).
  2. Move the items back to the iBooks folder. Start with one if you want to see that it works first.
  3. Let it sync. The iBooks iCloud badges and the Upload/Download list (available from the down-arrow button at the top-right of iBooks) should actively reflect the syncing.
0

This simple trick worked for me:

  1. Go to System Preferences > iCloud > iCloud Drive options
  2. Uncheck iBooks and check it again

All the books showed up again in iBooks on the Mac and were available for syncing in iTunes.

  • I'd tried initially this but it didn't work for me. – Siniša Šašić Jul 20 '17 at 11:51

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .