1

Recently time zone was changed in Turkey. It was UTC + 2, now opting out of DST, time zone is permanently UTC + 3. All iOS devices updated correctly.

However, on my Apple Watch, it asked for 'There is an updated Time Zone Settings, click OK to apply' or similar and I accidentally said no. Now it shows the wrong time.

How can apply the updated time zone settings?

I have tried restarting, updating to watchOS 3.0.1, airplane mode on/off, nothing seems to be working.

Any ideas?

| improve this question | | | | |
  • 1
    On your iPhone, go to settings, general, date/time. Disable auto time zone and switch to another time zone. Then switch back to your own time zone (maybe wait a bit for the watch to pick up the change?). I bet it will ask you again. – Alesh Houdek Nov 5 '16 at 18:02
  • @AleshHoudek Your suggestion worked beautifully. Thank you. If you write it as an answer, I'll accept it. – oyalhi Nov 6 '16 at 17:21
0

On your iPhone, go to settings, general, date/time. Disable auto time zone and switch to another time zone. Then switch back to your own time zone (maybe wait a bit for the watch to pick up the change?). It will ask you again.

| improve this answer | | | | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .