1

So I have Server 5.2 running on a Mac mini, running OS X 10.11.6.

I have two MacBook Pros trying to use it as a Time Machine server; the backup disk is offered to both MBPs when setting up Time Machine. I select Encrypted backups on both MBPs, and use the same credentials to connect to the disk on both, then enter encryption passwords for both.

Time Machine is set up successfully on both MBPs. They also both have SMB and AFP enabled under File Sharing.

One MBP backs up using Time Machine just fine, the other says that the backup fails because the network username and password are wrong. It suggests re-adding the backup disk. I've done this countless times, and triple-checked the credentials used on the second MBP, but I can't get the backup to work.

Any suggestions to advice? Thank you!

  • How did you check the credentials? – Allan Nov 4 '16 at 14:57
  • Using screen sharing - same user and password when I screen share the Mini. I can also see the Time Machine Password entry in the keychain and have double-checked the value there matches. – user209294 Nov 4 '16 at 15:28
  • Try validating with file sharing and see if that causes any errors – Allan Nov 4 '16 at 15:32
  • Hmmm; I mounted two volumes from the server, one using SMB and one using AFP. I used the same credentials as for Time Machine, a user that has an upper-case first letter. The SMB mount shows the user with an upper-case first letter, the AFP mount shows the same name with a lower-case first letter. So I changed the Time Machine disk to use credentials with a lower-case first letter, and that worked! Even though the Mini user is registered with an upper-case first letter. Thank you! – user209294 Nov 4 '16 at 15:39
  • Excellent, thanks! I'll remove mine to get your props bumped up :) – user209294 Nov 4 '16 at 15:49
1

So, the problem was that the second MBP needed the Time Machine server credentials User in all lower case. The Mac mini has a local user, let's say Arthur. I configured the second MBP to use the credentials Arthur/(a password) and the connection wouldn't work. Configuring it as arthur/(a password) worked just fine.

Thanks to Allan I found this by mounting two volumes from the Mac mini, one using SMB and one using AFP, and noticed that the AFP mount showed the user as 'arthur', and the SMB showed the user as 'Arthur', even though I'd logged in as Arthur for both mounts.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .