0

Since upgrading to macOS Sierra (10.12.1 non-beta), I can no longer enter the keyboard combination Command+Shift+Up Arrow or Command+Shift+Down Arrow. I use this in text editors to select everything above or below my text cursor. On the macOS Keyboard Viewer, when I press the combination, only the Command and Shift keys show as pressed down.
Command+Shift+Left/Right Arrow works just fine though.

I'm not sure what's going on. I haven't found anyone else with this problem on Sierra. I used to have Karabiner installed, but uninstalled it after finding it wasn't compatible with Sierra. I also had Karabiner Elements installed for a bit, but uninstalled it as well. Restarting doesn't do anything to change the problem. The problem occurs on both my MacBook Pro keyboard and my external keyboard.

  • Have you tried resetting both the SMC and NVRAM? Also, what happens if you boot into Safe Mode? – Monomeeth Nov 4 '16 at 4:27
  • I have now reset the SMC and NVRAM. The problem is the same. – Eugene Nov 7 '16 at 1:49
  • What about if you boot into Safe Mode (i.e. Hold the Shift key down while booting up until you see the Apple logo)? – Monomeeth Nov 7 '16 at 1:52
  • Right, sorry. It looks like it works fine in Safe Mode! – Eugene Nov 7 '16 at 2:04
1

Since it works in Safe Mode (based on your comment) we know it's definitely a software issue.

Basically, when you boot into Safe Mode your Mac will check the startup disk, only load necessary kernel extensions, and disable third-party fonts and startup options. Put simply, it won’t load third-party hardware drivers or startup programs.

It's likely (although not certain) that something to do with your prior installation of Karabiner is causing the problem. Your question didn't specify what version of Karabiner you had installed (besides the fact you also tried Karabiner Elements) or how you removed it. Assuming you've removed and deleted the application itself, there may still be other files installed. I would do the following:

Check the top level 'Library' folder of your hard disk for anything that looks like it's associated with your Karabiner installation. In particular, look at the following locations:

/Library
/Library/Caches
/Library/Preferences
/Library/Application Support
/Library/LaunchAgents
/Library/LaunchDaemons
/Library/PreferencePanes
/Library/StartupItems

If you find anything, delete the files.

Now, also do the same thing with the same set of folders within your User's Library folder. To access this, within the Finder click on the Go menu while holding the Option key and select Library.

Let us know how you go.

  • I did that now, still no effect. There were things to delete from Library/Cache/, Library/Preferences/, and Library/Application Support/, and I restarted afterwards. I didn't see anything in my User's Library folder. It's possible that I could've missed something, but I doubt it. – Eugene Nov 7 '16 at 18:33
1

I think I fixed the problem by finding out there was a kernel extension named org.pqrs.driver.VirtualHIDManager from an old Karabiner installation that was running and causing this problem. It was in my boot volume at /Library/Application Support/org.pqrs/Karabiner-Elements/org.pqrs.driver.VirtualHIDManager.kext/. I didn't notice it earlier. Removing org.pqrs didn't work while I was logged in, so I restarted into my recovery volume, mounted my boot volume, and used the terminal to remove the directory. Everything went back to normal after that. Thanks to Monomeeth for the suggestions.

I found the definitive problem. It turns out, the problem was caused by an application called Noiz.io on my Mac that launches on login. With the default settings, the application uses Command+Shift+Up Arrow or Command+Shift+Down Arrow as shortcuts for application volume. It apparently does so by hijacking the input of these keys so they don't even appear in Keyboard Viewer. I fixed it by removing the shortcuts from the application settings page.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .