1

I'm troubleshooting a new external hard drive. It isn't readable on the computer it was bought for (my mother's). It worked fine, at first, on my computer with OS X installed but she has Parallels and a leftover installation of Bootcamp. When we setup Parallels she tried to remove Bootcamp but the removal failed so it's still sitting there as we left it. I don't know if the failed removal is contributing to this problem (it's sitting on 300MB of unusable space).

On her Mac, the external drive doesn't show up in Finder (on Windows it isn't in Device Manager or Disk Management at all, even to show that it needs a driver or formatting), it only shows up under Disk Utility and then the indented subentry is greyed-out. It shows 0 bytes free but on my Mac it was not greyed out and shows its full 5TB are free.

I tried running Erase to reformat it to MSDOS FAT (from Windows NT, that it came with) but that has failed.

In Disk Utility, the Info that seems relevant:

Writable No
Available Space (purgeable + free) 0
Purgeable space 0
Free space 0
Can be verified 0
Can be repaired 0
Bootable 0

Initially First Aid said:

Checking prerequisites
Checking the partition list
Checking the partition map size
Checking for an EFI system partition
Problems were found with the partition map which might prevent booting
Operation successful.

When Erase failed:

Unmounting disk
Creating the partition map
Waiting for partitions to activate
Formatting disk3s2 as MS-DOS (FAT) with name S B+ 5TB
Mounting Disk
Could not mount disk3s2 after erase
File system formatted failed.
Operation failed...

Now running First Aid:

Repairing file system.
** /dev/rdisk3s2

Invalid BS_jmpBoot in boot block: 000000

File system check exit code is 8.
Updating boot system partitions for the volume as required.
File system verify or repair failed.
Operation failed...

I have tried plugging it into my Mac again and it has the same Info, but slightly different error when I ran Erase:

Unmounting disk
Erasing
newfs_msdos: S B+ 5TB: bd volume name

Mounting disk
Could not mount disk2s2 after erase
File system formatter failed.
Operation failed…

I realize the disk name of rdisk3s2 and disk2s2 is only different because the two computers are naming it differently. Also, S B+ 5TB is the shorthand for the name I was giving it: Seagate Backup+ 5TB (their own troubleshooting page was helpful to a point).

  • Maximum volume size for FAT is 4TB. I'd have another go at formatting GUID/HFS+ or GUID/NTFS [depending on your Mac's toolkit, NTFS won't be available without Paragon NTFS or similar] The drive was probably MBR/NTFS initially, rather than GUID – Tetsujin Nov 3 '16 at 16:23
  • Ah, there's a basic fact I forgot. Thank you, that explains that part at least. – Carryl Nov 3 '16 at 16:47
  • Got it working now. I repartitioned the computer's main drive to remove Bootcamp and despite hanging and having to force quit, that seems to have worked. I had also tried booting into Recovery Mode, but it couldn't see the external hdd at all. Just tried GUID/NTFS which still wouldn't mount the drive, but GUID/HFS+ has done the trick (I didn't realise that was usable on Windows). Thanks again for your help. – Carryl Nov 3 '16 at 17:07

You must log in to answer this question.

Browse other questions tagged .