I've got an IPv6 tunnel from Hurricane Electric, configured into one of my Apple Airport Extremes (which is otherwise setup in bridge mode).

That's all fine, except that in the IPv6 Route Advertisement messages the Airport Extreme then insists on advertising itself as a DNS server for the local LAN.

I don't want this, as I've got perfectly good BIND instances on my network performing DNSSEC validation and the Airport's DNS server doesn't do this.

Is there any way to disable that functionality?

1 Answer 1


That's a sneaky one - I'm sure you looked into the Airport Utility configuration. Tried to assign a static IPv6 to it? Fiddle with IPv6 DNS& share setting.

I don't know if there is a way to turn off the RA - since they are supposed to "maintain" network quality, and this is a connect&forget device so maybe that's a default and it's fixed. I dont know a way to send ipv6 nd ra suppress all to it :-)

If you assign a static IPv6 to a rr, it still uses the info from the RA's in the ICMPv6 (type 134) that comes along to get the default gateway and/or the mac+link local from the first hop. See what happens when you fill static IPv6 where possible.

  • The thing is I actually want the ND RA, because that's how my client devices get their IPv6 connectivity. I just don't want the automatically generated IPv6 RDNS option to appear within the RA.
    – Alnitak
    Commented Dec 21, 2016 at 9:11
  • I looked into some not-so-deep docs and couldn't find anything about possible settings for RDNS or even something about RA :-/ but since it's an interesting issue I will dig more and I'll let you know – have you found something out on yourself?
    – PJJ
    Commented Dec 22, 2016 at 1:57
  • no, I've found nothing useful :(
    – Alnitak
    Commented Dec 22, 2016 at 8:56

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .