Have any of you faced some problems with the new Lion Mission Control after migrating from Snow Leopard.

I have the following two problems.

  1. The Finder window is generally hidden. When it is hidden, I have to context-click the Finder dock icon and select option -> This desktop.

  2. Using quicksilver to switch apps, generally the apps will be hidden behind another app. For instance, switching from an alternate application to Firefox I will be shown Finder (with Firefox completely hidden behind it).

NOTE: The issue of Item 2 is when using full screen mode, a new feature in Lion, and could be the source of the issues.

As a last resort, I will be performing a new clean install. Does anyone have suggestion as to how I may fix these issues without having to perform a clean install?

  • We are having some of the same issues here. There is obviously a compatibility issue between the Spaces preferences and Mission Control when migrating over to Lion. Haven't found a solution yet, but I wonder if you switch off all of the preferences in Spaces before migrating whether the issue would persist.
    – user13147
    Commented Nov 3, 2011 at 1:47
  • That might work. I even tried deleting all the spaces configurations.. it did not work still.
    – billygoat
    Commented Nov 4, 2011 at 4:27
  • I have definitely been having similar issues, one in particular is switching from apps via command + tab when multiple window of the same application are in full screen mode, e.g. two full screen Chrom windows open, when command + tabing back and forth, often the window I was NOT previously working in gets brought into focus while the one I was previously working in gets selected (then I hit a bunch of keys and wonder why nothing is happening only to realize the other window just had all it's tabs closed or something, very frustrating!).
    – rudolph9
    Commented Jun 25, 2012 at 18:21

1 Answer 1


As far as my understanding of your question goes,

The Finder window, is almost always is hidden. I have to context-click the Finder dock icon and select option -> This desktop.

Well, why would you expect it to always be visible?

When I click Finder in the Dock, it either shows an existing window or creates a new one on the last space I've used it on and switches me to that space. Here, Finder is no different from any other application.

One thing you may want to do is to set the setting you mentioned to All Desktops so the window is displayed on each space. By doing so, you'll be able to skip the screen-switching hustle when you're working on several desktops and need a Finder window here.

Choosing This Desktop setting binds new windows to open on the specified desktop so I fail to see how it helps you.

Most of the time, the apps will be hidden behind another app. For instance if I am switching to Firefox. I will be shown Finder (with firefox completely hidden behind it).

I am not sure what you're talking about because I'm not a Quicksilver user but let me give you a couple of suggestions.

Firstly, if any app is in Lion fullscreen mode, there is no way to put something “below” it—in fact, it contradicts the very idea of fullscreen mode.

Secondly, why don't you just use Dock and Mission Control together to switch between apps?

Swipe four (or three, depends on you Trackpad settings) fingers up to get a view of current screen, then just swipe left and right with three fingers to switch between desktops and fullscreen apps.

Last, I doubt this has anything to do with a clean install—rather, you seem to have some misunderstanding about how Dock and/or Mission Control work, and probably the program you're using (Quicksilver) may have issues with Lion (which I can't confirm or disconfirm). If you still have issues, please indicate your exact steps, expected and actual outcome so we can understand the problem.

  • May be the question is not very clear. What do you expect, when you click on finder in dock?, you would expect a new finder window... right...? I know a new window opened... bt its not visible... (in any of the desktops..)
    – billygoat
    Commented Sep 25, 2011 at 22:42
  • No, I would expect it to bring focus to an already open Finder window. If there is *none*—yes, I would expect it to open a new window. How do you know the window is “not visible”? Could it just be appearing in some odd place of the screen, small-sized or something? Does you menu bar switch to “Finder”? If it does, can you try File > New Finder Window?
    – Dan
    Commented Sep 25, 2011 at 22:48
  • context click on the finder dock item, mentions the list of open finder items.. I do not think, that it is appearing in some obscure corner.. ( I have hot corners to show all app windows.. I can see finder stacked in there, bt it disappears when i try to click it..)
    – billygoat
    Commented Sep 25, 2011 at 23:09
  • This is really odd, don't think I can help here. Try creating a new user and see if the problem persists. Then, try re-installing the system.
    – Dan
    Commented Sep 25, 2011 at 23:19
  • Having a similar problem--expose selects the window but does not switch to its desktop. Migrated from SL. Create a new user, it works. So, is there a way to reset the MC/Expose/Spaces settings?? Definitely not about to reinstall the entire system for this. Commented Feb 4, 2012 at 23:16

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .