I am using Photos 2.0 (451.20.9) on macOS Sierra 10.12.1 (16B2555) and new Photos are not downloaded. This only happens on one machine (pictures on iCloud.com are OK, as well as on a second Sierra machine and two iOS devices).

I tried

  • to repair the Photos library (by pressing command+option after starting it
  • disabling Photos in the iCloud settings (with the warning that everything will be deleted) and re-enabling it

enter image description here

The Photos settings just show that it is uploading (?) but nothing happens

enter image description here

Same result: I get my pictures up to one month ago.

Photos shows

enter image description here

but nothing happens (even after a couple of days and reboots).

Any idea on how to force a sync?

  • Same issue, except I only get photo's up to May 2015...
    – Joe
    Commented Nov 2, 2016 at 14:45
  • Is it possible your Mac is going to sleep or disconnecting from the internet at some point? Nothing will download to your Mac from iCloud until everything uploads to iCloud. Your image says it's still uploading and I think that needs to complete first.
    – fsb
    Commented Nov 7, 2016 at 16:48
  • The mac was online for days without a single change in the number of pictures that should be uploaded according to the message.
    – Matteo
    Commented Nov 7, 2016 at 17:11
  • Matteo, Did you ever get this figured out? I have the same issue with photos going from iPhone and iPad to iCloud immediately, but not going to my iMac. I turned off Photo Library on my iMac which prompted another 19000 photo upload which seems to be stuck at 28.32GB of some 76GB. All this started after 6/15/17 when I would notice pictures weren't appearing on my iMac and it would say at the bottom - 1 item updating, but nothing ever happened. Commented Jul 26, 2017 at 1:53
  • Hi, after several tries by deleting everything and resyncing it now seems to work
    – Matteo
    Commented Jul 26, 2017 at 6:10

1 Answer 1


First, confirm that My Photo Stream is enabled on your Mac by going to the Photos app, then Photos > Preferences in the menu bar. Click the iCloud tab and ensure the My Photo Stream box is checked. Second, confirm the same on your iPhone or iPad by going to Settings > iCloud > Photos. The My Photo Stream option should be turned on there. If both of these are already set correctly, follow the steps below:

  1. On your Mac, quit the Photos app.
  2. Launch the Activity Monitor app, which is located under Utilities in the Applications folder.
  3. In Activity Monitor, search for “photos” in the upper-right to filter through the list of running processes.
  4. There should be a few rows left on the screen. For “Photos Agent” and each of the ones starting with “com.apple” click on the row to select it, and then click the X icon in the upper-left.
  5. A confirmation message will appear. Click “Force Quit” to end the process.
  6. Once all of the processes mentioned in step 4 are gone, you can quit Activity Monitor.
  7. Open the Photos app again and, after a few moments, all of your latest photos should start importing from My Photo Stream.

From My Photo Stream not updating in Mac Photos app

  • 1
    Photostream is enabled and the photos are available on iCloud.com. Killing the processes is not really necessary as the situation is the same after a reboot. I will update my question.
    – Matteo
    Commented Nov 5, 2016 at 12:38
  • I understand that, can you you still entertain us by trying it.. I have said many things on here that seem to make no sense and have worked ;) Commented Nov 5, 2016 at 12:41
  • I tried, in the question I just mentioned the reboots (as no process can service a reboot) but killing (or quitting) the processes does not change my situation.
    – Matteo
    Commented Nov 5, 2016 at 12:47
  • And actually the processes are re-startet ... (after killing)
    – Matteo
    Commented Nov 5, 2016 at 12:58
  • 2
    Killing “Photos Agent” did not work for me Commented Mar 20, 2020 at 20:11

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .