I have a Macbook Pro, model A1502. While watching videos, the screen just cut to black. Now it won't do anything on boot - the MacBook screen just comes up black. I've tried zapping the PRAM, (ahem, NVRAM), an SMC reset, nada. It seems that the backlight is working - it's "LCD black" black, meaning it's not truly dark it looks like the backlight is working.

Safe boot, boot to recovery, verbose safe boot, nothing happens.

I have an external monitor. On the external, it shows the apple boot screen, the progress bar gets to about 40% across, then even the external monitor goes black.

My guess is, hardware issue, Genius Bar time? I hope not... don't feel like buying a new board.

EDIT: it needed an SMC reset. I didn't do it properly, and it did work, eventually.

EDIT2: 1) you don't want a full battery for an SMC reset. I always had it charging. I unplugged from power and plugged in some spinning-rust hard drives to sap power. This helped. 2) I found mirror mode. Command F1 mirrors the main login screen to the external monitor. I can then login do a backup and wipe the drives

3 Answers 3


It honestly seems like you have already tried everything a genius bar would try themselves. However I think I might have some attempts here to help you out.

All boot-up key combinations can be seen from here: https://support.apple.com/en-us/HT201255

  1. Remove all connected USB, HDMI, or other plugged in devices including power cable. Try booting again with holding option to select a disk. I recommend doing this after steps 2 + 3, but remove cables first.

  2. Lets ensure you are indeed resetting the SMC. This works best without 100% battery, because the light will be orange when charging and the computer is off. While off and the light is orange, hold down shift+control+alt/option and then after holding those three keys hold the power button a moment and release and watch the light change from orange to green to orange again. Volume should also get reset from this. (This can be done without any issues involving firmware password)

  3. Clearing NVRAM by holding Command-Option-P-R. NOTE: This will require your firmware password to clear it, but I don't think it will clear with one as I've noticed it doesn't for my MBPr mid 2012. So if you can, remove the firmware password and then try this. But from a command-line terminal the following command will also clear your NVRAM.

Requires Administrator privileges! This is also funky with MacOS Sierra due to new restrictions with their attempts for a new secure system meaning it'll require you to be in safe mode to run it.

sudo nvram boot-args -c

I have more info on boot-arguments if necessary. Just ask.

  1. Boot into Internet recovery by holding Command+option+R (Differs from normal recovery because this downloads your original factory release OS recovery rather than using the partition of your current OS on disk.)

  2. If it is hardware, lets try Apple's Intel CPU check by holding down 'D' while booting up. This is a hardware test and takes a while.

Let me know how you make out.

  • It needed an SMC reset. Evidently my reset didn't take because it worked at the Genius Bar. Commented Nov 3, 2016 at 3:37

I recently had the problem of the black screen with cursor. There are many possible reasons for that and most of them of them are alarming and hint at hardware failures. Following this post, I found out that this is simply due to a corrupted configuration file that messes with the login window. So, instead of reinstalling the whole system, boot in single-user mode (hitting command-S at the chime) and then mount the filesystem (using the instructions at the boot) and then type

rm /Library/Preferences/com.apple.loginwindow.plist

and then


to reboot.

This solved it for me.


I had the same problem my 2013 MacBook booted but the screen stayed black. The diagnostics reported VFD002. I tried a lot of things and all the different key combinations to reset NVRAM etc.

In the end I could fix the problem by pushing on the cable that connect the mother board to the display. For this you have to open the MacBook (checkout the videos on YouTube) and find the connector for the cable. I pressed slightly on the connector and that solved the problem.

See also here for a similar solution to this problem.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .