4

I am getting "ctkahp quit unexpectedly" regularly on my macOS Sierra 10.12.1 Mac Mini.

I cannot find any resources about what this process is.

When this error occurs, my machine can't connect to the internet at all and I get a ton of errors, iCloud, etc.

I have to reboot to make it go away.

  • ctkahp is part of the CryptoTokenKit framework introduced in Yosemite. How do you connect to the internet? – tubedogg Nov 2 '16 at 2:28
  • wifi & ethernet (both are active). – emd Nov 12 '16 at 3:54
  • Perhaps it was a firewall issue, e.g. like Snitch or Flocker? – New Alexandria May 19 '17 at 22:16
1

Had the same problem in an environment that uses Active Directory. When I attempted to run Chrome, I would get the error. The error mentioned the CryptoTokenKit, or something like that.

Oddly enough, other accounts on the same machine worked fine.

When I dug deeper, I found that the client did NOT have a Mobile Me account. Setting them up with a Mobile Me account appears to have solved the problem.

  • How did you set up a Mobile Me account in 2017? – nohillside Dec 12 '17 at 13:17

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .