0

I have setup a working Open Directory Master on on Mac-Server-1 running macOS Sierra and macOS Server 5.2 (latest as of today). I have also successfully started the Device Manager and enrolled a client computer with no problem.

I have now also setup a working Open Directory Replica on Mac-Server-2 running MacOS Sierra and macOS Server 5.2. However, when I try to activate the Device Manager on the Replica, it stays Disabled.

Is this by design that Device Manager can only be active on the Master? Or is this a bug?

Steps:

  1. In macOS Server -> Profile Manger -> Device Manager, status is Disabled
  2. In macOS Server -> Profile Manger -> Device Manager, I click Setup... button
  3. New window appears telling me I can manage devices. I click Next
  4. The window now changes and asks me for a Name, E-mail, Telephone, and Address (presumably to generate a certificate?)
  5. I enter the info, and click Next
  6. The next window appears, telling me to click Finish. I do.
  7. The window disappears, returning me to the macOS Server -> Profile Manger window, where the status of Device Manager still shows as Disabled

Ideas?

Edit1: I tried uninstalling Server.app and deleting /Library/Server/* and reinstalling the Replica from scratch. Same behavior.

Edit2: I tried reinstalling the entire server from scratch. Same behavior.

  • no one has any experience with a multi-site macOS (or OS X) Server setup? – Daniel Nov 4 '16 at 17:47
1

I believe that Profile/Device manager needs the full Certificate authority (to sign profiles) that is only available on the OD master, so it is probably by design.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .