2

I've been trying for a couple of ways in every way imaginable to create a Netboot image for sierra.
Up until now I've tried doing the following:
- Mounting the disk from a vm and using that as source
- Using the Install Sierra.app as source
- Using a tool like autoNBI
- Doing the whole workflow through the automator

But when using the disk image utility it always gives error 2 after the "Creating cache" step.
Any clues?

Creating a netrestore image is no problem by the way..

I tried running the commandline tool imagetool instead. It gave me a very similar error. Here is the complete output:

imagetool --netboot --index 2000 --source /Volumes/Macintosh\ HD\ 2 --destination '/Users/Styleshoots/Desktop/netboot\ images/' --name 'sierra netboot'

2016-11-01 14:20:46.182 imagetool[788:13710] Imaging failed. Error: Error Domain=System Image Utility Code=2 "(null)"
2016-11-01 14:20:46.596 imagetool[788:9044] imaging tool has completed '/Users/Styleshoots/Desktop/netboot\ images.nbi'
2016-11-01 14:20:46.596 imagetool[788:9044] image creation took 536.859359 seconds.
  • Have you followed Apple's Guidelines and here? – IconDaemon Nov 1 '16 at 11:57
  • Indeed I have, point for point – J. Meijers Nov 1 '16 at 11:59
  • Make sure you're updated to 10.12.1, I ran into a lot of issues creating images with 10.12.0 which are better in the latest update. – MacManager Nov 15 '16 at 15:56
  • Have you gotten anything to work? – William May 6 '17 at 14:00
1

I have the same problem using the imagetool command or the System Image Utility app on macOS Sierra.

As a semi-solution (workaround?), you could follow the steps on this web page that shows how to create a NetBoot image (.nbi) using the Install Sierra.app as source. I was able to create a "plain" NetBoot image with these steps. I assume you could also customize stuff using additional Installer packages and post-install scripts.

I'm still looking for a (free-style, good-old) way to create a NetBoot image from a custom bootable macOS Sierra partition though.

  • I did, I don't have the solution with me any more, but I remember that inside of the imagetool, there are a couple of shellscripts and there was a variable somewhere that defined the maximum cache size. I figure it would run out of space. I hope this helps – J. Meijers May 8 '17 at 18:21

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .