Usually after I open quicklook and then close it again I cannot open quicklook again. And if I right click on an icon it lists exit quick look as an option but when I click it nothing changes.

What's my problem here?

I am on OSX 10.11.6

  • Try triggering QuickLook with space bar press? – owlswipe Nov 7 '16 at 22:08

Try the following:

  1. Open the Terminal application (/Applications/Utilities/Terminal.app)
  2. Type qlmanage -r and hit enter
  3. Type qlmanage -r cache and hit enter
  4. Close Terminal and restart your system

This should force QuickLook to reload the generator lists and reset the disk cache.

Source: https://www.macissues.com/2014/03/22/fix-quicklook-errors-in-os-x/

|improve this answer|||||
  • That seems to have worked for now, however usually after a fresh restart it does work for a short period. I will come back if I have problems again, but for now you win – Chris James Champeau Nov 11 '16 at 17:36
  • 1
    This is back to not working again. I don't feel like I should have to do this once a week – Chris James Champeau Nov 19 '16 at 23:53
  • It could perhaps also be a plugin from a 3rd party that is breaking something. For example when you install Adobe Illustrator, it adds the ability to view .ai files in quick look. Have you noticed if it happens with a certain file type at first or have you installed any specific software that could cause this? You can use qlmanage -h to give you some tools for debugging quick look, if you feel comfortable using this. – Morten Andersen Nov 20 '16 at 13:47

Pressing the function key and the spacebar fixed it for me.

|improve this answer|||||

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .