I've recently downloaded an app. I can confirm it worked in OS X El Capitan, but it doesn't open anymore in macOS. When opening the app, I basically get a pop-up saying that the app is not supported with my version of macOS. I can confirm it is not a PowerPC application. I tried opening the app via Terminal. When trying that, I get the following result.

; exit;
objc[674]: Objective-C garbage collection is no longer supported.
Abort trap: 6
logout
Saving session...
...copying shared history...
...saving history...truncating history files...
...completed.
Deleting expired sessions...none found.

Is it still possible to open the app using another method? If not, could someone explain me why?

up vote 2 down vote accepted

I'm afraid the garbage collection feature of Objective-C was deprecated back in 10.8 in favor of Automatic Reference Counting or ARC. Now with the release of Sierra, this feature appears to be officially obsolete. Most likely this means the feature was completely removed from the Objective-C runtime, so there is no way to continue to run old applications that depend on this feature.

The application will need to be updated to the new ARC system to work on the newest versions of OS X. Alternately I suppose you could run it in a VM with an older OS X version.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.